Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

Console VT320 out of order

 
SOLVED
Go to solution
Highlighted
Frequent Advisor

Console VT320 out of order

Hello ,

I have a old VAX 4000/300 ; OS VMS 5.5-2.
The Vax Digital VT320 console is out of order.
I have no spare but I found a VT220 console.
When I power it on , I get : VT220 OK , but when I press enter or return , I only get a blinking echo.
Can anyone tell me if VT220 is compatible with a VAX 4000/300 ?
And if yes , please what are the good parameters to enter for working .
(speed parity xon xoff ...)
Thank you.
What could I say ?
17 REPLIES 17
Highlighted
Honored Contributor

Re: Console VT320 out of order

Gilles,

no problem using a VT200 for a console.
Likely connection values would be

speed 9600 8 bits No parity


Dunca
Highlighted
Frequent Advisor

Re: Console VT320 out of order

Thank you Duncan.

I already try that and same behavior.
There are so many parameters and menu ...
eg xoff 64 128 or none and so on ...
Do you know where I could find a complete
parameter list and values ?


What could I say ?
Highlighted
Honored Contributor

Re: Console VT320 out of order

Gilles,

it is unlikely that the flow control will really affect this.

If you are not getting any response then I would look to the session settings - make sure that you are on the correct port on the console etc. Are you sure that this terminal was working beforehand?

The installation guide is here:

http://www.retrocomputing.net/info/siti/vt100/vt100.net/docs/vt220-in/ek-vt220-in-001.pdf


Duncan
Highlighted
Frequent Advisor

Re: Console VT320 out of order

Duncan,


I read the pdf manual.
It is well connected and I get the VT220 OK.
Yesterday the vt320 was down but the server still up.
Today I can't ping it and don't know in which status it is as I have no display.

Do you think that I need to electrical reset all ?

Gilles.
What could I say ?
Highlighted
Honored Contributor

Re: Console VT320 out of order

> The Vax Digital VT320 console is out of
> order.

It's about time. Most of them died within a
few years of entering service. Bad
horizontal output transformers. Although
older, a VT220 is much more likely to keep
working.

> When I power it on , I get : VT220 OK , but
> when I press enter or return , I only get a
> blinking echo.

If it's not connected to anything, and it's
not in Local mode (and local echo is off),
then you won't see what you type.

Connect pins 2 and 3 to change this (for a
test). (And don't enable hardware flow
control.)

> Can anyone tell me if VT220 is compatible
> with a VAX 4000/300 ?

Practically any VTxxx (or even VTxx) terminal
is compatible with practically any VAX.

If you connect it to the VAX and still see
nothing when you type, then I'd worry about
the cable. Are you using the same cable as
before, or a different one?

> There are so many parameters and menu ...

Reset to the factory defaults?
Highlighted
Frequent Advisor

Re: Console VT320 out of order

Hello Steven,

I reset to default then save and power-off/on
the Vax ==> still not working.

I don't understand that :
"Connect pins 2 and 3 to change this (for a
test). (And don't enable hardware flow
control.)"

what are you talking about ?
I only connect the keyboard in the KB .
And the console cable into the adaptor.
I use the same console cable than on the vt320.
There is a red digital display on the server
with a : 3 ==> 2400 bauds.
What could I say ?
Highlighted
Honored Contributor

Re: Console VT320 out of order

> what are you talking about ?

I know nothing about your cable(s). Doesn't
your VT220 have a 25-pin D connector? It
should have pins 2 and 3. You should try
connecting them together.

I only connect the keyboard in the KB .

Ok.

> And the console cable into the adaptor.

Huh? What adaptor? My psychic powers are
very weak.

> [...] 3 ==> 2400 bauds.

Really? I'd expect 9600. In any case, the
terminal speed settings should match those of
the thing it's connected to.
Highlighted
Trusted Contributor

Re: Console VT320 out of order

You used the same cable for the VT220 that you used on the VT320?

How?

Every VT220 I ever saw had a 25-pin connector for EIA-232 and a "mate'n'lock" connector for 20mA current loop, and perhaps a 9-pin connector for a local printer.

Every VT320 I ever saw just had MMJ connectors.

It seems to me that the same cable will not work for both without additional adapters for one or the other.

So how do you have it connected up? What connector on the VT220? What connector on the VAX?
Highlighted
Honored Contributor

Re: Console VT320 out of order

http://vt100.net/dec/vt320/serial_connections

says that at least some VT320 terminals had a DB25 connector in addition to MMJ.

An old PC and a terminal emulator is another option that has many advantages (for example being able to cut and paste error messages into a forum such as this). You will need an emulator that has support for a serial connection, and a PC that has an RS-232 connection. You man also need a PC DB9-to-DB25 cable to attach the DB25 to MMJ converter to.

Jon
it depends