Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

%LOGIN-F-CLIFAIL after upgrade vom 7.3-2 --> 8.3A

 
Highlighted

%LOGIN-F-CLIFAIL after upgrade vom 7.3-2 --> 8.3A

Hello,

we are experiencing a problem with a self written command langauge interface after upgrading our Alpha from 7.3-2 to 8.2A.
The error message is quit simple:

%LOGIN-F-CLIFAIL, error activating command interpreter

We have everything compiled, linked, and installed again but it doesn't help.

The user normally get the CLI in SYSUAF changed to our (called mibs.exe). I did some testing by using spawn:

CVSR1> spawn/cli=mibs
%DCL-S-SPAWNED, process DEP10872_1516 spawned
%DCL-S-ATTACHED, terminal now attached to process DEP10872_1516
Error activating command interpreter SYS$SYSTEM:MIBS
Normal successful completion
%DCL-S-RETURNED, control returned to process DEP10872_8
CVSR1>

Of course mibs.exe is installed with the right protections...

Any ideas ?
Thomas
18 REPLIES 18
Highlighted
Honored Contributor

Re: %LOGIN-F-CLIFAIL after upgrade vom 7.3-2 --> 8.3A

Thomas,

welcome to the OpenVMS ITRC forum ;-)

As far as I'm aware, the interface for writing CLIs is not documented and not supported. I also couldn't immediately find any examples on the net.

I certainly know someone, who may have more information about this. You could send me mail (look at my profile in ITRC) or give me a call - I still have the same mobile phone number as in the 'Digital' days.

Volker.

Highlighted
Honored Contributor

Re: %LOGIN-F-CLIFAIL after upgrade vom 7.3-2 --> 8.3A

Until the expert on MIBS gets in, a simple question:
did You rebuild the CLI on the 8.2 system.
It was a major system version step, and I can imagine the CLI is linked /SYSEXE , is it ?
http://www.mpp.mpg.de/~huber
Highlighted
Honored Contributor

Re: %LOGIN-F-CLIFAIL after upgrade vom 7.3-2 --> 8.3A

Until the expert on MIBS gets in, a simple question:
did You rebuild the CLI on the 8.2 system ?

It was a major system version step, and I can imagine the CLI is linked /SYSEXE , is it ?
http://www.mpp.mpg.de/~huber
Highlighted

Re: %LOGIN-F-CLIFAIL after upgrade vom 7.3-2 --> 8.3A

Yes, we linked with /sysexe on VMS 8.3...
Highlighted
Honored Contributor

Re: %LOGIN-F-CLIFAIL after upgrade vom 7.3-2 --> 8.3A

Writing a command line interpreter (CLI) has never been documented, AFAIK.

Something in the CLI interface has changed, at least as far as your MIBS CLI is concerned. Undocumented APIs have always had the risk of instability, and clearly something in sys$cli or in the resulting control region or related context has changed here.

Assuming a full rebuild of the code has been performed and no errors are reported and the code is installation matches that of DCL, dig up the OpenVMS source listings, fire up xdelta or the system code debugger or such, and have at.

And as for using the listings, the first pass would be a search for any MIBS code and for the OpenVMS code that can emit the CLIFAIL status, and work backwards.

Or (if you're not inclined to go for a "swim" in supervisor mode, and in the source listings) call in somebody familiar with working within privileged-mode code on OpenVMS Alpha, and have them take a look at the MIBS code on OpenVMS Alpha V8.2. There are folks here that are.

And no, I don't know what might have changed here within sys$cli and friends, nor within the P1 control region space. It could be as simple as a change to a data structure layout. (Or not. A simple structure size change would usually be picked up by a recompile or reassemble; by a full rebuild.)

Stephen Hoffman
HoffmanLabs LLC
Highlighted
Honored Contributor

Re: %LOGIN-F-CLIFAIL after upgrade vom 7.3-2 --> 8.3A

Thomas,

the only reference to %LOGIN-F-CLIFAIL I could find is from a TCPIP troubleshooting article in Ask Compaq:

- the CLI image must be protected WO:RE

What's also questionable in the error message output from your SPAWN test is the secondary status of SS$_NORMAL !

Looks like CLIFAIL is signalled from LOGINOUT, if the call to map the CLI into P1 space (LIB$P1_MERGE) fails. The correct failure status (other than SS$_NORMAL) would be helpful.

Volker.
Highlighted
Honored Contributor

Re: %LOGIN-F-CLIFAIL after upgrade vom 7.3-2 --> 8.3A

I would also re-compile (Macro? c?) and then re-link.

The CLI may well pick up a structure layout from LIB.MLB or some such.

Hein.

Highlighted

Re: %LOGIN-F-CLIFAIL after upgrade vom 7.3-2 --> 8.3A

Of course we recompiled the MACRO32 and C-Source. I will have a closer look at the very beginning of the code, maybe something goes immediately wrong.

I was told that writing CLI's was documented with VAX/VMS 3.x.
This piece of code is used since than and also ported to Alpha VMS without any problems.
Highlighted
Honored Contributor

Re: %LOGIN-F-CLIFAIL after upgrade vom 7.3-2 --> 8.3A

Did you check accouting, audit and operator log for abnormal messages/alarms ?

Did you install the image correctly (would expect "must be installed" but don't have 8.x to test). I got messages in audit when I deinstalled the image in 7.3.

Wim
Wim