Operating System - OpenVMS
Showing results for 
Search instead for 
Did you mean: 

LPD died "no logical name match"

Go to solution

LPD died "no logical name match"

Hi all,
I have a 3 node cluster running OpenVMS 7.3-1 and TCPIP 5.3.
I got a strange situation with the LPD queues yesterday. Suddenly all printerjobs run into "Retained on error" together with the error message "%SYSTEM-F-NOLOGNAM, no logical name match".
Here's an example,
Entry Jobname Username Blocks Status
----- ------- -------- ------ ------
40 AA0442 HBO 2 Retained on error
%SYSTEM-F-NOLOGNAM, no logical name match
Completed 1-FEB-2007 14:41:11.67 on queue EK451
I deleted the que/recreated it but with the same error as before. Then I restarted LPD, no success, same error as before. I shut down TCPIP, run into trouble when tried to start it again, the inet processes seemed to be there, but I could'nt reach the host via IP.
So at last I had to reboot the host, and everything worked again.
Any ideas ? What logical name can it be ?
I thought that the reason could be lack of some system resource, but dont known which.
I cant find any logs with clues either.
Hope someone have a clue..

Regards /Arne Korpas
Honored Contributor

Re: LPD died "no logical name match"

Your sequence looks like some part of TCP/IP Services or of OpenVMS itself got its knickers in a twist. (I generally go for reboot before reconfiguration, but that's personal preference.) it could easily be a leak or such, there was a recent leak fixed via ECO in the V8.* range. (Probably not related to this, but leaks happen.)

Check the LPD logs -- usually stored somewhere like SYS$SPECIFIC:[TCPIP$LPD] -- and check that the device and logical name references inside the printcap files are available. But if some part of TCP/IP outside of LPD itself tipped over, that may or may not show up within the context of LPD and its logs.

Also check the operator log, and check the accounting data. You might find clues there. And poke around for other IP logs, and for any process-related logs or dump files from around the time of the LPD error.

If you do reboot to clear this sort of thing, I'd suggest a yellow sticky note -- kudos to the guy that invented those -- with the forced-crash sequence. Stick this on the console terminal, and use it to force the creation of a carcass in the system dump file when the system is grossly misbehaving. When good software goes bad, it's massively easier if there's still a warm body around to autopsy.


I'd look for the ECO kit for TCP/IP Services V5.3, and I'd consider an upgrade to V5.4 with ECO. Even if the ECO kit does not overtly address the problem, preemptive installation still quicken the trip through the HP support organizations. I'd also go after mandatory OpenVMS ECO kits, and anything related to FC and SCSI drivers, and (for this case) Networking. The usual "shotgun" suggestion, but this also cures a surprising number of the weird cases. And OpenVMS Alpha V7.3-2 has the freshest ECO kits for all of V7.*, those around for V7.3-1 will be somewhat stale.


Re: LPD died "no logical name match"

Hello Hoff,

Thank you for a great answer, I cant find any clues in the logs though, so I think I will go for an upgrade, I feel that it is the right thing to do when you get funny things in the system and dont have the latest eco's installed.

/Arne Korpas
Trusted Contributor

Re: LPD died "no logical name match"


Your sure TCPIP$LPD_ROOT is configured ?
Normaly you don't need to much LPD logicals, but if TCPIP$LPD_ROOT isn't on the systemdisk or moved nonstandard of TCPIP$LPD probably is to be the problem. The logical point unfortunaly to :[SYSx(not common).TCPIP$LPD] by default. In a multinode clusterenvironment including multisite environments this is the wurst case you can think of.
But alright, another way of printing is TELNETSYM. If you aren't using printlibraries you can use LPD, if you are using printlibraries you CAN NOT use LPD printing.

The best thing is to look at operator.log or use the LPD debug logicals to get more information.

NL: Meten is weten, maar je moet weten hoe te meten! - UK: Measuremets is knowledge, but you need to know how to measure !

Re: LPD died "no logical name match"

Hi Anton,

The system has been running for several years now, so LPD is absolutely configured.
The problem came all of a sudden and disappeared after the reboot, I will probably upgrade TCPIP on this node and hope to avoid these kind of strange errors after that, and I will probably get new ones instead :)

Thanks anyway /Arne
Occasional Advisor

Re: LPD died "no logical name match"

I had this problem today on a system running VMS V7.3-1 and TCPIP V5.3 Eco 1.

The logical name missing was TCPIP$INET_HOST:

"TCPIP$INET_HOST" = "test"
"UCX$INET_HOST" = "test"

Something to check if someone else gets this problem.