Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

OpenVMS (Alpha V6.2-H3)Application troubleshooting

 
SOLVED
Go to solution
Highlighted
Super Advisor

OpenVMS (Alpha V6.2-H3)Application troubleshooting

Hi,
We have running av specific application for more than 10 years without trouble. (:-))

Suddenly we got trouble with the application
Error message says following:

"missing math argument". It's strange se we have run the same application for many years nowwithout trouble.

Hope OpenVMS have som tools I can use for application/and or OpenVMS troubleshooting?
13 REPLIES 13
Highlighted
Trusted Contributor

Re: OpenVMS (Alpha V6.2-H3)Application troubleshooting

Geir,

Nothing just stop working.......
Have you done anything to the system prior to the errors ?

A VMS system looks like %DCL-W-IVVERB,......
Is "missing math argument" the only thing reported ?

Hakan
Don't make it worse by guessing.........
Highlighted
Honored Contributor

Re: OpenVMS (Alpha V6.2-H3)Application troubleshooting

hi,

this sounds like it's from within your application, do know what it is written in and do you have access to the source code ?

Highlighted
Respected Contributor

Re: OpenVMS (Alpha V6.2-H3)Application troubleshooting

Hello Geir,

I agree that it sounds like it's coming from your application. If you could tell us more about it, such as any layered or third party products it uses (databases, messaging, transaction monitors, etc) that might be helpful.

Where did you see this error message? Is it in a log or error file, or does it pop up on someone's terminal screen? If it's a log file, is there anything else immediately preceeding this message?

Do you have the source code for this application?

Has anything in the environment changed? Has the workload changed?

You need to give us much more information if we are to help you.

Brad McCusker
Software Concepts International
www.sciinc.com
Brad McCusker
Software Concepts International
Highlighted
Honored Contributor

Re: OpenVMS (Alpha V6.2-H3)Application troubleshooting

Geir,

As has been noted, this message is not in the standard OpenVMS format.

Some condition has changed. As a start, I would suggest attempting to identify precisely where the message came from.

The question of whether sources exist is critical. Without sources, solutions are difficult. As a start, I would suggest trying to identify the source of the message by using SEARCH to see where the message is coming from.

If there is little knowledge of the internals of the application, it could be an interesting and challenging hunt.

- Bob Gezelter, http://www.rlgsc.com




Highlighted
Super Advisor

Re: OpenVMS (Alpha V6.2-H3)Application troubleshooting

Hi,

The problems are not caused by applications. Yesterday the server needed several tries to reboot (third try). T oday it's not possible to boot at all.

The error messages vary from try to try. But some of them are:

1: HWRPB invalid
2: unable to load SYS$BASE_iMAGE.EXE, base
3: +++
Highlighted
Honored Contributor

Re: OpenVMS (Alpha V6.2-H3)Application troubleshooting

hi,

what system is this on ? can you boot from cd ?

Highlighted
Respected Contributor

Re: OpenVMS (Alpha V6.2-H3)Application troubleshooting

Geir,

> 1: HWRPB invalid

You more than likely have a hardware problem.

Do you have an alternate boot capability? Can you boot off a CD?

Brad McCusker
Software Concepts International
www.sciinc.com
Brad McCusker
Software Concepts International
Highlighted
Honored Contributor

Re: OpenVMS (Alpha V6.2-H3)Application troubleshooting

hi,

do you get any error messages if you do an ínit' in the srm console.

Highlighted
Super Advisor

Re: OpenVMS (Alpha V6.2-H3)Application troubleshooting

Hi,

Thanks to all. Agree, it must be a HW-failure. Fortunately we have HP support on all servers.

Is it possible to run a specific command from eeprom/console mode to collect more info??

Rgds
Geir

PS:
I will try to boot from a CD