Operating System - OpenVMS
Showing results for 
Search instead for 
Did you mean: 


Occasional Visitor


I am running OpenVMS v7.3-2 on an AlphaServer ES40 6/667 running TCP/IP Services V5.4 ECO 7.


When I run SFTP in batch mode to rename a bunch of files - sometimes a rename will fail with the "%TCPIP$_SSH_FX_PERM_DENIED, insufficient privileges to perform the operation" message.  This seems to happen randomly in one out of 8 to 10 batch runs.  I may have 10 files to rename and it fill fail on the 7th one, but the rest will complete.  In the attached log, the batch stream renames 4 files, the 3rd one fails, but 1,2 & 4 complete.  I have run the SFTP with the "-D99" debug mode and attached the log.


I have tried the following images with the same results:

TCPIP$SSH_SFTP2                         "V5.4-ECO7"

TCPIP$SSH_SFTP2                         "V5.4-ECO7J"

TCPIP$SSH_SFTP2                         "V5.4-ECO7M"


Does anybody have an idea as to why this happens?


Rick Lade


Army & Air Force Exchange Service


Honored Contributor


Honored Contributor


I would also like to see the file protection before and after. We know the initiating system is OpenVMS, but what's the target running?


As a 1+ to Steven's suggestion, I'm not sure if the new feature of CREATE/FDL was ever documented, you can give it an FDL string directly, so


$ create /fdl="RECORD; FORMAT STREAM_LF"  'sftpbfile'
$ open /read /write sftp_bfile 'sftpbfile'

I think this goes back as far as V7.3.


I'd also like to see the contents of the sftp batch file which is generating the error (rather than having to reverse engineer it from the remainder of the log). The D99 stuff is pretty useless, just extra noise.

A crucible of informative mistakes