Operating System - Tru64 Unix
Showing results for 
Search instead for 
Did you mean: 

Re: Creating a large File System

Go to solution
Occasional Advisor

Creating a large File System

Hi again!!

I´m trying to create a 500 Gb FS but i can´t:

es40001>#mount -o extend oracle_dmn#bdfs /bdfs
mount: Extending AdvFS file system..
WARNING: cms_mount:preprocess: not VROOT!!!!!!

oracle_dmn#bdfs on /bdfs: Specified device does not match mounted device

The size is 1006632960 on partition c, the fstype is AdvFS, and size/fstype of the rest of partitions are 0/unused..

What can I do?

Than you!

Honored Contributor

Re: Creating a large File System

It looks like this file system is already mounted. I assume you've already done the addvol command. For an already mounted file system, the mount command must include the '-u' switch to extend. Like this:

# mount -u -o extend oracle_dmn#bdfs /bdfs

This must be done as the root user.
If that doesn't work for you please post the output of:

# showfdmn oracle_dmn
# ls -l /etc/fdmns/oracle_dmn
# df -k | grep bdfs

Re: Creating a large File System

A quibble on the previous reply: if you're using addvol, then mount -o extend isn't appropriate. AdvFS will automatically add the size of the new volume to the domain. Mount -o extend is necessary only if you've increased the size of an existing volume that already had the filesystem on it; for example, by redefining the size of a virtual disk on a storage controller or increasing the size of an LSM volume.

However, Mark did touch on the key piece of missing information: what did you do BEFORE trying to extend the filesystem? Did it already exists, or are you trying to create it for the first time? (If you're creating a brand new filesystem, then just mkfdmn and mkfset would do the trick.) If the filesystem already existed, exactly what did you do to increase the available space?

I work for HPE
A quick resolution to technical issues for your HPE products is just a click away HPE Support Center
See Self Help Post for more details

Accept or Kudo

Occasional Advisor

Re: Creating a large File System

First of all..thank you,

When i use the "mount -u -o extend oracle_dmn#bdfs /bdfs" i recive the same response. If i try to mount without the "-o -extend" the FS mount, but with a very small size.

The showfdmn sais: "domain is not active!"

es4001> # showfdmn oracle_dmn

id date Created logPGS Version Domain Name

4a7fc010.00077610 Mon Aug 10 08:37:04 2009 512 4 oracle_dmn

showfdmn: unable to display volume info; domain not active

At last:
ls -ltr /etc/fdmns/oracle_dmn

lrwxrwxrwx 1 root system 15 Aug 10 14:40 dsk3c->/dev/disk/dsk3c

Thank you again, regards,

Occasional Advisor

Re: Creating a large File System

Hi Martin!

Acording with your response, i thought that "-o extend" was to create a "big size fs".. but this is wrong, my fs (volume, domain) is new so i should´t use it even a volume with 500 Gb
Occasional Advisor

Re: Creating a large File System

Hi... i solved the problem!!!!

The Mark explanation was very important to resolve the question...

I need to mount a NEW fs with 500 Gb

1.- Bad way:

mount oracle_dmn#bdfs /bdfs
NOTICE: Size of virtual disk /dev/disk/dsk3c is 1006632960 blocks. AdvFS is only using 20971520 blocks.
Use the '-o extend' mount option to extend the filesystem.

As i said previously the filesystem was mounted with a small size.

So i UNMOUNTED the filesystem and then executed the "mount -u -o ..." BUT THIS IS WRONG.

2.- The correct way (2 steps):

# mount oracle_dmn#bdfs /bdfs

# mount -u -o extend /bdfs

Thank you for your help, kinds regards,

Occasional Advisor

Re: Creating a large File System

Sorry, really Martin gave me the key ... :-)
Occasional Advisor

Re: Creating a large File System

Thanks, the problem is solved