ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Configuring B120i Controller

 
Highlighted
Occasional Advisor

Configuring B120i Controller

Hey folks.

I've been trying to configure B120i in my DL380e Gen8 for a few hours now. I'm trying to configure it with one 120GB SSD (server is used for testing purposes).

I booted into Intelligent Provisioning. When I select the controller, I'm greeted with the following errors (please check picture). Cables are correcly connected and SSD is in correct bay.

Are there any solutions to this?

iLo.png

8 REPLIES 8
Highlighted
HPE Pro

Re: Configuring B120i Controller

Hi, 

The B120i is a SATA Controller and the drive used should be a SATA drive. Is this a SFF drive or an M.2?

Regards,

Vador

I am an HPE Employee

Accept or Kudo

Highlighted
Occasional Advisor

Re: Configuring B120i Controller

Thanks for your reply!

It's a Samsung 840 EVO SSD. It's an ordinary SATA SSD drive.

 

EDIT: added aditional screenshot; controller does not see the drive.

iLo2.png

Highlighted
HPE Pro

Re: Configuring B120i Controller

Check the controller settings in the BIOS & ensure the controller is set to SATA RAID:

Select System Options>Embedded SATA Configuration>Enable Dynamic HP Smart Array B120i RAID Support.
 
Please make the changes & check if the drives are detected.
 
Thank you
 

I am an HPE employee
Accept or Kudo
Highlighted
Occasional Advisor

Re: Configuring B120i Controller

Thanks for your reply!

I am confirming that RAID Controller is enabled and selected in BIOS.
Controller still doesn't show any drives.

I also updated Intelligent Provisioning. After update, it still doesn't see any drives.
BIOS and iLO are also up-to-date.

Highlighted
HPE Pro

Re: Configuring B120i Controller

Does the server have a Hot Plug Backplane or Non Hot Plug Backplane?

Was the SSD's tested on any other server & found to be working good?

Has another SSD tested on the server to check if the server detects any other Drives? A normal SATA drive can also be tested on the server to confirm the server Drive Backplane, Cables & the Controller works fine.

Share a photo of the cable connection from the SATA ports on the System Board to the Drive backplane

Please verify the drive backplane information to identify what type of Drives it supports.

Thank you


I am an HPE employee
Accept or Kudo
Highlighted
HPE Pro

Re: Configuring B120i Controller

Hi,

Please provide an update & let us know if you were able to isolate the issue. Have you tested any other normal SATA drive in the server to check if the issue is with the Drive Bay or the Drive itself.

Thank you


I am an HPE employee
Accept or Kudo
Highlighted
Occasional Advisor

Re: Configuring B120i Controller

Hi,

we have installed P420 into it and it works fine. But it's a shame that we had to buy P420 just for one drive...

Kind regards.

 

Highlighted
HPE Pro

Re: Configuring B120i Controller

Hi,

If the same SSD works fine with P420 controller, then definitely the settings are not correct in the BIOS to recognize the SSD when connected to B120i controller.

Please Note: P420 is a Smart Array controller, B120i is only a Dynamic controller.

Connecting the SATA cable to the correct port is also important. There will be multiple ports on the System Board to connect the SATA cable to the Drives. Need to ensure the cable is connected to the correct port. The Drive Backplane should also be a supported one to work with the SATA drive.

Thank you


I am an HPE employee
Accept or Kudo