ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

SUM 8.5.0: "requires" command broken

 
Highlighted
Advisor

SUM 8.5.0: "requires" command broken

After upgrading SUM to version 8.5.0 smartupdate requires seems to be broken:

 

[root@server ~]# smartupdate requires
Invalid option, pass install or remove with script


[root@server ~]# smartupdate --help
Smart Update Manager 8.5.0

For CLI (legacy command) information:
    smartupdate  --s [--help | --h]

To start Smart Update Manager in interactive GUI mode:
    smartupdate   [--port <#>] [--ssl_port <#>] [--ftp_port <#>] [--open_firewall]  [--overridedb]

To use interactive console mode:
    smartupdate <console_command> [--help | --h]

Supported console commands:

        activate
        add
        configure
        delete
        deploy
        findavailablenodes
        generatereports
        getattributes
        getbaselines
        getcomponentlogs
        getcurrentlyinstalledversions
        getenginestatus
        getlogs
        getneededupdates
        getnodes
        inventory
        login
        setattributes
        shutdownengine

    For further command information, please issue:
        smartupdate <command> [--help | --h]


To use firmware RPM console CLI using yum or zypper repository mode:
        smartupdate <command> [--help | -h]

Supported firmware RPM console CLI commands using yum--zypper repository:
        requires
        list
        upgrade
        info
        query


[root@server ~]# rpm -q sum
sum-8.5.0-2.rhel7.x86_64

 

 

OS is RHEL 7.7

"Historisch gewachsen."
1 REPLY 1
Highlighted
Honored Contributor

Re: SUM 8.5.0: "requires" command broken

Yes, there is already a thread on this and I have reported the issue to the team that maintains SUM

No support by private messages. Please ask the forum!