Server Management (Insight Manager 7)
1820636 Members
1930 Online
109626 Solutions
New Discussion

SNMP 100% CPU use on NT4

 
Ayman Altounji
Valued Contributor

SNMP 100% CPU use on NT4

I'm using 4.80 agents on several NT4 servers. After some time the snmp process uses all cpu power an degrades server performance.
When I restart the snmp service things are ok again for about 45 minutes and then the same scenario starts all over again
I upgraded 1 server to 5.00 agents but this did not resolve the issue
Anybody have a clue what this could be ?
thx in advance.
1 REPLY 1
Ayman Altounji
Valued Contributor

Re: SNMP 100% CPU use on NT4

Take a look at the following Microsoft Article, it solve the same problem for us.

PSS ID Number: Q196270
Article last modified on 11-16-2000

winnt:4.0




======================================================================
-------------------------------------------------------------------------------
The information in this article applies to:

- Microsoft Windows NT Workstation version 4.0
- Microsoft Windows NT Server version 4.0
- Microsoft Windows NT Server, Enterprise Edition version 4.0
- Microsoft Windows NT Server version 4.0, Terminal Server Edition
-------------------------------------------------------------------------------

SYMPTOMS
========

Severe memory leakage occurs when the SNMP agent is under stress.

Also, in Perfmon, for the Network Interface Object, you may notice a random
number for the first instance, instead of 1.

CAUSE
=====

This problem occurs because, while processing messages, a buffer was used that
was never freed.

A regression in Service Pack 4 caused the network interface problem.

RESOLUTION
==========

To resolve this problem, obtain the latest service pack for Windows NT 4.0 or
the individual software update. For information on obtaining the latest service
pack, please go to:

- http://www.microsoft.com/Windows/ServicePacks/

-or-

- Q152734 How to Obtain the Latest Windows NT 4.0 Service Pack

For information on obtaining the individual software update, contact Microsoft
Product Support Services. For a complete list of Microsoft Product Support
Services phone numbers and information on support costs, please go to the
following address on the World Wide Web:

http://support.microsoft.com/directory/overview.asp

This fix is now part of the Post-SP4 Roll-up fix, which is available at the
following Internet location as Sp4hfixi.exe (x86) and Sp4hfixa.exe (Alpha):

ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/usa/NT40/hotfixes-postSP4/Roll-up/

This fix can also be installed individually from the following Internet
location:

ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/usa/NT40/hotfixes-postSP4/archive/Sms-fix/

This fix is for all versions of Windows NT, except Windows NT, Terminal Server
Edition, which needs to be requested by calling Microsoft Product Support
Services.

STATUS
======

Microsoft has confirmed this to be a problem in Windows NT 4.0. This problem was
first corrected in Windows NT version 4.0 Service Pack 5.

Additional query words: 4.00 systems management server service sp4

======================================================================
Keywords : kbWinNT400sp5fix sms
Technology : kbWinNTsearch kbWinNTWsearch kbWinNTSsearch kbWinNTSEntSearch kbNTTermServSearch kbExchange400
Version : winnt:4.0
Hardware : ALPHA x86
Issue type : kbbug
Solution Type : kbfix
=============================================================================
Copyright Microsoft Corporation 2000.