Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

ESX Host not detecting properties in SIM

 
Highlighted
Frequent Advisor

ESX Host not detecting properties in SIM

I have about 40 ESX hosts and all of them are detected by SIM just fine. They are all built from an image and seem to be identical. I have two of them that I can't get SIM to detect any of the details like model and OS. It comes up as Unknown. I pulled out a mirrored harddrive and I did get the alert in SIM. I've ran the Options > Identify and it said the following:

Checking for SNMP support on system.
The system did not respond to SNMP, verify security settings and community strin
gs.
.
.
.
Running HP ProLiant management agent identification
The system does not support SNMP.

Not sure where to take this. If the other boxes are working fine with the same settings what could be different about these two systems?

2 REPLIES 2
Highlighted
Honored Contributor

Re: ESX Host not detecting properties in SIM

SNMP is used to ID the server, from the above the trapsink setting is correct. You should also have a setting like:
rocommunity OurROCommunity HPSIM.ourco.com

This is what should allow HPSIM access.

You should also check that SNMP has been allowed access through the ESX Firewall. Typically the HP Agent install checks and enables that if required.
Highlighted
Frequent Advisor

Re: ESX Host not detecting properties in SIM

I made the fatal mistake of "assuming" that since the servers were all built from an image that the settings were identical. We all know the dangers of assuming.

The firewall settings on a working server look like this:

Opened ports:
NaviCLI : port 6390 tcp.in
hp-sim : port 2301 tcp.in
hpim : port 2381 tcp.in
sim-cert : port 280 tcp.out
NaviCLI : port 6391 tcp.in
NaviCLI : port 6389 tcp.in tcp.out
NaviCLI : port 6392 tcp.in

On the non-working machines it was:

Opened ports:
NaviCLI : port 6390 tcp.in
hp-sim : port 2301 tcp.in
NaviCLI : port 443 tcp.out
sim-cert : port 280 tcp.out
NaviCLI : port 6391 tcp.in
hpim : port 2381 tcp.in
NaviCLI : port 6389 tcp.in tcp.out
NaviCLI : port 2163 tcp.out
NaviCLI : port 6392 tcp.in

I ran the "esxcfg-firewall -allowincoming & -allowoutgoing command. I deleted the entries from SIM and rediscovered them. Now they are responding just fine.