Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

Incorrect Associated System State for critical event DL380 G3

 
Highlighted
Occasional Advisor

Incorrect Associated System State for critical event DL380 G3

Hi,

Got an odd problem with SIM 5.3 - one of my DL380 G3 servers correctly reports that it has a failed accelerator battery, but this is not show in the Health status column of SIM. When I checked the event log in SIM for the server, its listed as having occurred, but that the assocated system status for the event is 'Normal'.

I looked at the same critical event (3040) on an identical server, and its associated system status for the same event is 'Minor'.

How do I fix this, cos I haven't seen anywhere to change the system status for a reported event? I can see how to change the severity of an event, but not its associated system status.

Any help appreciated!!

Nick
9 REPLIES 9
Highlighted
Honored Contributor

Re: Incorrect Associated System State for critical event DL380 G3

hi,

you could try checking whether the logs in smh on the managed system are full up or delete the system and rediscover it. check patch levels are up to date etc.

hth

Highlighted
Occasional Advisor

Re: Incorrect Associated System State for critical event DL380 G3

Hi,

Thanks for the reply, I have already deleted and rediscovered it twice - the problem appears to be with the way that SIM itself handles the event - the System management homepage correctly reports a 'Minor' status, but when SIM recieves the event, the associated system status for the event is 'Normal', whereas it should be 'Minor'.

The other two identical servers report their accelerator batteries as being dead correctly, i.e. with a minor warning status in the HS column.

It's the only time that I've seen this type of problem, normally the SIM console reports a minor status, and the SMH shows nothing wrong! This is the exact opposite.

Thanks

Nick
Highlighted
Honored Contributor

Re: Incorrect Associated System State for critical event DL380 G3

Do all of the systems in question have the SNMP agents and the SNMP agents only? My guess is that the first unit has the ProLiant WBEM (WMI) Providers as well or instead.
Highlighted
Occasional Advisor

Re: Incorrect Associated System State for critical event DL380 G3

Hi,

thanks for the message - yes its SNMP only for these two systems, no WBEM is installed. Like I say, the SNMP traps are recieved, its just that for one of the servers, this particular event (accelerator battery failed) is being reported as critical, but has an associated system status of Normal - so the event is recieved and the colour of the icon changed, but it is simply changed from Green (normal) to Green (accelerator battery failed). Attached is a picture of the event from HPSIM showing the event reported as Normal on one server. The post following this shows the same event reported as minor on a different server.
Highlighted
Occasional Advisor

Re: Incorrect Associated System State for critical event DL380 G3

Here is the second server, reported as minor.
Highlighted
Honored Contributor

Re: Incorrect Associated System State for critical event DL380 G3

What is the RAID configuration of the two? And what version of the PSP is each running?
Highlighted
Occasional Advisor

Re: Incorrect Associated System State for critical event DL380 G3

Err, I'm not sure the raid config is relevant, but there are 3 controller cards in each, a 6400, a 5300 and the onboard 5i.

Each 6400 has 7 drives on each port in 2 MSA shelfs split into 3 logical mirrored drives with 3 partitions. (G, H, I)

Each 5300 has 5 drives on 1 port, and 14 drives on the other port in an external MSA array, again split into 3 mirrored drives, with 4 partitions. (C, D, E and F)

Each 5i has nothing attached.

PSP pack is 7.60A on both. The only difference I can see is that the server that reports the critical event as Normal, is running Management Agents 7.60.0.0, and the server correctly reporting is running 7.51.0.0. That really shouldnt make any difference though, becuase its still a critical event and should be reported as minor.
Highlighted
Occasional Advisor

Re: Incorrect Associated System State for critical event DL380 G3

Ahh, ok sorry, my bad - the acclerator failed message comes from the 6400 controller. (this is a well known bug with early firmware's since they dont charge the battery properly, and eventually kill it). The controller reporting correctly is running firmware 2.84, the other is running 2.34.
I will update and see what happens...

Thanks for the reply!

Highlighted
Occasional Advisor

Re: Incorrect Associated System State for critical event DL380 G3

Ok, I am up-to date with the firmware, but still have the same problem that the associated system state of this critical event is still reported as normal.
I've updated everything on this 2000 server to the latest version available in the repository, and have green ticks everywhere, and I know I should replace the battery, but I want to see this event reported correctly first. I'm starting to pull my hair out...

Anyone, please help!