Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

SIM6 installation problems

 
Highlighted
Occasional Advisor

SIM6 installation problems

I'm trying to install on a newly built Windows 2003 SP2 VM with 4 GB of RAM and loads of disk space. All of the components install up to the point where HP SIM itself needs to install. At that point it fails and I see an error in the event log: AdminTest service terminated with service-specific error 123456.

c:\hpsim.log contains the following:
[04-14-2010][17:22:07][Install Shell]Generating xml file is done.
[Wed Apr 14 17:22:07 UTC+0100 2010]Install Shell:Load: res://C:\SIM6000-win\hpsim\win\setup.exe/content\custom-summ.htm
[Wed Apr 14 17:22:07 UTC+0100 2010]Install Shell:buildDocumentationSelect()
[Wed Apr 14 17:22:07 UTC+0100 2010]Install Shell:getComponentTableHeight(maxHeight[330] cellWidth[650] funcs[object] selectedOnly[true])
[Wed Apr 14 17:22:07 UTC+0100 2010]Install Shell:Load: res://C:\SIM6000-win\hpsim\win\setup.exe/content\custom-summ-table.htm
[Wed Apr 14 17:22:07 UTC+0100 2010]Install Shell:window_onload()
[Wed Apr 14 17:22:07 UTC+0100 2010]Install Shell:window_onload()
[Wed Apr 14 17:22:10 UTC+0100 2010]Install Shell:btnInstall_onclick()
[Wed Apr 14 17:22:10 UTC+0100 2010]Install Shell:ValidDiskSpace()
[Wed Apr 14 17:22:10 UTC+0100 2010]Install Shell:check space 72795 1500
[Wed Apr 14 17:22:10 UTC+0100 2010]Install Shell:isDefaultInstanceName(instName[MSSQLSERVER])
[Wed Apr 14 17:22:10 UTC+0100 2010]Install Shell:Load: res://C:\SIM6000-win\hpsim\win\setup.exe/content\custom-install-progress.htm
[Wed Apr 14 17:22:10 UTC+0100 2010]Install Shell:buildDocumentationSelect()
[Wed Apr 14 17:22:10 UTC+0100 2010]Install Shell:getComponentTableHeight(maxHeight[365] cellWidth[490] funcs[object] selectedOnly[true])
[Wed Apr 14 17:22:10 UTC+0100 2010]Install Shell:Load: res://C:\SIM6000-win\hpsim\win\setup.exe/content\custom-status.htm
[Wed Apr 14 17:22:10 UTC+0100 2010]Install Shell:window_onload()
[Wed Apr 14 17:22:10 UTC+0100 2010]Install Shell:InstallComponent()
[Wed Apr 14 17:22:10 UTC+0100 2010]Install Shell:RunComponentInstall(fnInstall[function] nIndex[3])
[Wed Apr 14 17:22:10 UTC+0100 2010]Install Shell:launchAndMonitor dwRet == 0
[Wed Apr 14 17:22:10 UTC+0100 2010]Install Shell:component install Initial Start return code == 0
[Wed Apr 14 17:22:10 UTC+0100 2010]Install Shell:window_onload()
[Wed Apr 14 17:22:10 UTC+0100 2010]Install Shell:InstallComplete()
[Wed Apr 14 17:22:10 UTC+0100 2010]Install Shell:process exit code = 12
[Wed Apr 14 17:22:10 UTC+0100 2010]Install Shell:sStatus = Setup failed. Please refer to the C:\hpsim.log and \logs\initconfig.logfiles for details.
[Wed Apr 14 17:22:10 UTC+0100 2010]Install Shell:nStatus = 4
[04-14-2010][17:22:10][Install Shell]HP Systems Insight Manager
[04-14-2010][17:22:10][Install Shell]return code: 4
[04-14-2010][17:22:10][Install Shell]return msg: Setup failed. Please refer to the C:\hpsim.log and \logs\initconfig.logfiles for details.
[Wed Apr 14 17:22:10 UTC+0100 2010]Install Shell:InstallComplete(sStatus[Setup failed. Please refer to the C:\hpsim.log and \logs\initconfig.logfiles for details.] nStatus[4])
[Wed Apr 14 17:22:10 UTC+0100 2010]Install Shell:installComplete: sStatus = Setup failed. Please refer to the C:\hpsim.log and \logs\initconfig.logfiles for details. nStatus = 4
[Wed Apr 14 17:22:10 UTC+0100 2010]Install Shell:updateComponentStatus(sStatus[Setup failed. Please refer to the C:\hpsim.log and \logs\initconfig.logfiles for details.])
[Wed Apr 14 17:22:10 UTC+0100 2010]Install Shell:checkIfFailedInstallIsHPSIM()
[04-14-2010][17:22:14][Install Shell]HP Systems Insight Manager failed to install successfully. Setup cannot continue. Click "OK" to exit the installation.
[Wed Apr 14 17:22:14 UTC+0100 2010]Install Shell:HtmlFrame_QueryExit()
[Wed Apr 14 17:22:14 UTC+0100 2010]Install Shell:Cleanup()
[04-14-2010][17:22:14][Install Shell]Shutdown

Can anyone give me some pointers please?
23 REPLIES 23
Highlighted
Occasional Advisor

Re: SIM6 installation problems

I have exactly the same problem on a physical server (Windows 2003 Std R2 x64 SP2) with a remote SQL 2005 Sp2 instance. I read some other forum entries regarding potential issues with the service account password but even changing it to a simple word still gives the same error.

The last section of the installation log:
Fri Apr 16 14:11:46 UTC+0100 2010]Install Shell:component install Initial Start return code == 0
[Fri Apr 16 14:11:46 UTC+0100 2010]Install Shell:window_onload()
[Fri Apr 16 14:11:46 UTC+0100 2010]Install Shell:InstallComplete()
[Fri Apr 16 14:11:46 UTC+0100 2010]Install Shell:process exit code = 12
[Fri Apr 16 14:11:46 UTC+0100 2010]Install Shell:sStatus = Setup failed. Please refer to the C:\hpsim.log and \logs\initconfig.logfiles for details.
[Fri Apr 16 14:11:46 UTC+0100 2010]Install Shell:nStatus = 4
[04-16-2010][14:11:46][Install Shell]HP Systems Insight Manager
[04-16-2010][14:11:46][Install Shell]return code: 4
[04-16-2010][14:11:46][Install Shell]return msg: Setup failed. Please refer to the C:\hpsim.log and \logs\initconfig.logfiles for details.
Highlighted
Trusted Contributor

Re: SIM6 installation problems

Hello.

I have quite the same issue. The server is a W2003 R2 SP2 vm (ESX 4.0) with SQL 2005 Sp3.
When HPSIM starts installing, it fails and HPSIM.LOG file contains the following :

[Mon May 17 14:08:59 UTC+0200 2010]Install Shell:ValidDiskSpace()
[Mon May 17 14:08:59 UTC+0200 2010]Install Shell:check space 9645 1756
[Mon May 17 14:08:59 UTC+0200 2010]Install Shell:check space 30337 0
[Mon May 17 14:08:59 UTC+0200 2010]Install Shell:check space 26133 0
[Mon May 17 14:08:59 UTC+0200 2010]Install Shell:check space 2006 0
[Mon May 17 14:08:59 UTC+0200 2010]Install Shell:isDefaultInstanceName(instName[SIM])
[Mon May 17 14:08:59 UTC+0200 2010]Install Shell:Load: res://E:\Sim6\SIM6000-win\hpsim\win\setup.exe/content\custom-install-progress.htm
[Mon May 17 14:08:59 UTC+0200 2010]Install Shell:buildDocumentationSelect()
[Mon May 17 14:08:59 UTC+0200 2010]Install Shell:getComponentTableHeight(maxHeight[365] cellWidth[490] funcs[object] selectedOnly[true])
[Mon May 17 14:08:59 UTC+0200 2010]Install Shell:Load: res://E:\Sim6\SIM6000-win\hpsim\win\setup.exe/content\custom-status.htm
[Mon May 17 14:08:59 UTC+0200 2010]Install Shell:window_onload()
[Mon May 17 14:08:59 UTC+0200 2010]Install Shell:InstallComponent()
[Mon May 17 14:08:59 UTC+0200 2010]Install Shell:RunComponentInstall(fnInstall[function] nIndex[3])
[Mon May 17 14:08:59 UTC+0200 2010]Install Shell:launchAndMonitor dwRet == 0
[Mon May 17 14:08:59 UTC+0200 2010]Install Shell:component install Initial Start return code == 0
[Mon May 17 14:08:59 UTC+0200 2010]Install Shell:window_onload()
[Mon May 17 14:08:59 UTC+0200 2010]Install Shell:InstallComplete()
[Mon May 17 14:08:59 UTC+0200 2010]Install Shell:process exit code = 12
[Mon May 17 14:08:59 UTC+0200 2010]Install Shell:sStatus = Setup failed. Please refer to the C:\hpsim.log and \logs\initconfig.logfiles for details.
[Mon May 17 14:08:59 UTC+0200 2010]Install Shell:nStatus = 4

Can someone help us solving this issue ?
Thank you.
Highlighted
Trusted Contributor

Re: SIM6 installation problems

Hello.
Using Procmon.exe, I see the thread setup.exe exits immediately after the following events :

- RegOpenKey HKLM\Software\Microsoft\Windows NT\CurrentVersion\GRE_Initialize
- RegQueryValue HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\GRE_Initialize\DisableMetaFiles (reply : name not found)
- RegCloseKey HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\GRE_Initialize

If someone from HP could reply, I need this server to be installed this week. I wil ltry to open a case with HP also.
Highlighted
New Member

Re: SIM6 installation problems

I had the same issue too, but I hadn't read the instructions properly, and was still on Internet Explorer 6. Once I upgraded to Internet Explorer 8, all worked fine.
Hopefully, this will be it for you!
Highlighted
Honored Contributor

Re: SIM6 installation problems

i had same error. what SIM log says?
sim\logs\mxdomainmgr0.log? attache that lets see if i can help?

did you try re-installing?
Highlighted
New Member

Re: SIM6 installation problems

I ran into the same issue and the resolution (for me) was to change the default of using DEP for all programs to using DEP for just Windows programs.
Highlighted
Honored Contributor

Re: SIM6 installation problems

A number of the logfiles here have:
Please refer to the C:\hpsim.log and \logs\initconfig.logfiles for details

Is there anything in that?
Just a guess but have the database pre-requisites been done, especially if you're using an external dataabse you need to ensure the account has full access.
Highlighted
New Member

Re: SIM6 installation problems

We had the same problem.
Using DEP for just Windows programs solved the problem.
Thank you!
Highlighted
Trusted Contributor

Re: SIM6 installation problems

Hello.
My problem is solved.
Windows update was showing messages about installing the latest patches for several days.
The CMS is hosted in a datacentre and patches are applied by the datacentre management team (third party). However this server is not currently in production so I decided to apply the patches and reboot.

After the reboot, the installation worked perfectly. I mention that I rebooted the server several times before but without installing the patches. So the reboot is not what solved my problem.

Regards.