Showing results for 
Search instead for 
Did you mean: 

Serviceguard assertion failed error

New Member

Serviceguard assertion failed error

I am getting the following error when I run a cmquerycl command. It does not matter with combination of switches I use with cmquerycl.

[root@host conf]# cmquerycl -v -n n130 -n n129
Gathering storage information
Gathering network information
Assertion failed: net->flags & \ CF_USER_SPECIFIED_NET, file: \ config/config_net_query.c, line: 440
[root@host conf]#

It also does not matter which host I run the query command from.

This is on two DL380 (G5) running RHEL4u4, 64bit.

Host 1 is the head node in a high performance cluster running Scali manage.

Host 2 is an NFS server for the high performance cluster. It also is the Data Protector Cell server.

SG is being install for NFS. SG is A.11.18 for Linux, and has been patched with SGLX_00191.

It has been mentioned that the assertion error is due to having different versions of SG on the two servers. I have verified that they are both identical versions.

Thanks in advance,
Honored Contributor

Re: Serviceguard assertion failed error

"Assertion failed" is a debugging message that should never happen in production-state software. The fact that it happens indicates that some internal assumption of the software was not true.

Based on the text on the "Assertion failed" message line, it seems to be related to network settings in some fashion. Is there anything unusual in the network configuration of your nodes?

You should open a support call with HP to get this investigated.

New Member

Re: Serviceguard assertion failed error

There are a lot of crazy things going on with the network because it is a High Performance Cluster. We have the standard private and public networks, a heardbeat network for SG, and IP over Infiniband.

I tried issuing the cmquerycl command with the "-w none" option to try to avoid checking the network, but I still get the assertion error.

Support has not found an answer yet which is why I posted here in the forum, and I have already be escalated. I was hoping someone had seen this before.