Showing results for 
Search instead for 
Did you mean: 

serviceguard on linux / change hostname


serviceguard on linux / change hostname

my lxsg (SG A.11.18, RHEL4.5) used to work with its old hostnames....
i changed my nodes hostnames...
- changed /etc/hosts,
- /etc/sysconfig/network,
- regenerate rsa keys on /root/.ssh on both nodes
- verified /usr/local/cmcluster/conf/cmclnodelist
- also tried re-running sgEasyConfig to recreated cluster files

but when i tried to do a cmquerycl, i get:
[root@weppra conf]# cmquerycl -c test -n weppra -n wepprb -C /usr/local/cmcluster/conf/TEST.ASCII -v
Permission denied to
Permission denied to
Looking for nodes in cluster test ... cmquerycl: Unable to obtain information for test: No such file or directory.
Either cluster test is not configured, or the user doesn't
have access to view the cluster configuration.

i can do ssh vice-versa on both nodes...
cmscancl output:
[root@weppra conf]# cmscancl -n weppra -n wepprb

The nodes to be scanned are: weppra wepprb
The output file is: /tmp/scancl.out
Checking cmexec access to all the nodes...

cmscancl: Can not cmexec to the system wepprb.

i tried to manually start sg daemon:
[root@wepprb init.d]# ./cmcluster.init start
tcp 0 0* LISTEN
udp 0 0*
cmviewconf: Unable to connect to Serviceguard daemon or cmclconfd on the local node.
Check the syslog file for more information.
cmrunnode : Unable to connect to the local cluster: Permission denied.
User root on node wepprb doesn't have access to view the configuration
ERROR: Unable to join cluster

all inputs appreciated in advance...
thanks for reading...


Re: serviceguard on linux / change hostname

recreate the cluster on UI resolves this.