Software Defined Networking
cancel
Showing results for 
Search instead for 
Did you mean: 

OpenFlow v1.3 Negotiation

 
SOLVED
Go to solution
Highlighted
Advisor

OpenFlow v1.3 Negotiation

Hi all,

I'm using Mininet v2.2.0 as a testing platform and I want the controller and the virtual Mininet network to communicate using OpenFlow v1.3. The problem is that when the virtual network connects, the negotiated version according to the controller web interface is v1.0. The command I use for this regular connection is

sudo mn --topo=linear,4 --controller=remote,ip=10.4.0.95,port=6633

 

If I create the Mininet network with a specified/mandated OpenFlow version of 1.3 using this command:

"sudo mn --topo=linear,4 --controller=remote,ip=[controller IP],port=6633 --switch ovsk,protocols=OpenFlow13"

 , then I get error messages when I try to view the flows. I've attached a screenshot of what I see. I've checked that the OpenvSwitch Controller supports 1.0 and 1.3, so my suspicion is that there is something in the controller that I must configure for it to support or explicitly negotiate OpenFlow v1.3.

 

Any advice?

2 REPLIES 2
Highlighted
Valued Contributor
Solution

Re: OpenFlow v1.3 Negotiation

Hi ssrirama,

 

You can configure mininet  to run version 2.3 of OpenVswitch by running the "install.sh -nfV 2.3.0" from the "util" directory in the "mininet" directory:

 

root@ubuntu:~/mininet/util# ./install.sh -nfV 2.3.0

 

this will allow the controller and OVS to negotiate version 1.3 of Openflow and you will not need to specify the OF version in the mininet command.

After running the above command I run the following command:

 

sudo mn --topo=linear,4 --controller=remote,ip=[controller IP],port=6633 --switch ovsk

 

and I'm able to run dpctl dump-flows without getting errors.

Please check the attached images showing what I can see from both the dump-flows output and the version negotiated shown in the controller GUI(notice that I'm running mn version 2.2.0b2, you might want to upgrade your version as well).

 

Please let me know if this solves your issue.

 

Regards,

 

Antonio

SDN Team

 

 

 

Highlighted
Advisor

Re: OpenFlow v1.3 Negotiation

Yes, that worked for me. Thanks!