Software Defined Networking
cancel
Showing results for 
Search instead for 
Did you mean: 

VAN not listening on port 8443 after install

 
Highlighted
Visitor

VAN not listening on port 8443 after install

Hi,

we are trying to get 2.5 running on another box and are having similar issues to the people above. VAN doesn't want to bind to ipv4 8443. The VM has 9 GB ram and 4 vCPUs. See requested output below. This is a fresh install of Ubuntu 12.04

uname -a
Linux hyperglance 3.13.0-32-generic #57~precise1-Ubuntu SMP Tue Jul 15 03:51:20 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

$ sudo service sdnc status
sdnc start/running, process 1093

$ sudo service sdna status
sdna start/running, process 1096

$ sudo service keystone status
keystone start/running, process 1100

$ sudo dpkg -l | grep -i sdn
ii hp-sdn-ctl 2.5.11.1149 HP VAN SDN Controller
hyperglance@hyperglance:~$ sudo dpkg -l | grep -i keystone
ii keystone 1:2014.1.4-0ubuntu2~cloud0 OpenStack identity service - Daemons
ii python-keystone 1:2014.1.4-0ubuntu2~cloud0 OpenStack identity service - Python library
ii python-keystoneclient 1:0.7.1-ubuntu1~cloud0 Client library for OpenStack Identity API

$ netstat -na | grep 8443
tcp6 0 0 :::8443 :::* LISTEN
tcp6 38 0 127.0.0.1:54266 127.0.0.1:8443 CLOSE_WAIT

2 REPLIES 2
Highlighted
Esteemed Contributor

Re: VAN not listening on port 8443 after install

The output of the netstat command does indicate that the server is listening on port 8443 for both IPv4 and IPv6. I see the same output on my server and it is working beautifully.

 

I believe the issue is that many browser updates have disabled the use of DSS based certificates and that is what the controller installs by default as a self-signed cert.

 

Try Internet Explorer as it hasn't removed support for these certs yet.

 

And stay tuned for a doc to be published on how to update the self-signed cert using RSA. Or look at this post:

 

http://h30499.www3.hp.com/t5/SDN-Discussions/Error-accessing-SDN-UI-after-browser-update/td-p/6733864#.VTUfmSF4q70

Highlighted
Regular Visitor

Re: VAN not listening on port 8443 after install

I also encountered the same symptoms when initially attempting to upgrade from v2.4 to v2.5 and subsequently when attempting a clean install on 12.04 ubuntu.

 

What did work on a clean install was NOT creating the sdn user during initial setup of ubuntu. Instead, use ubuntu/ubuntu (or something other than sdn/password) to install Linux. After successfully installing Linux, login to the ubuntu account to unpack and install the HP SDN Controller software.

 

This allows the installation process to create the sdn user with the correct attributes and permissions.

I work for HP.