Switching and Routing
cancel
Showing results for 
Search instead for 
Did you mean: 

Ports in trunk flapping

 
Highlighted
Occasional Contributor

Ports in trunk flapping

Hi,

I have an existing trunk with 6 ports configured on a 5412, The connecting switch is a 5406. I have tried to 2 addtional ports to this trunk (8 ports in total) but the 2 newly added ports is flapping, and I canøt figure out why.

Trunk config swtch 1:

Port | Name Type | Group Type
------ + -------------------------------- ---------- + ------ --------
C1 | Uplink_SW_202 100/1000T | Trk3 Trunk
C2 | Uplink_SW_202 100/1000T | Trk3 Trunk
C21 | Uplink_SW_202 100/1000T | Trk3 Trunk
C22 | Uplink_SW_202 100/1000T | Trk3 Trunk
D7 | Uplink_SW_202 100/1000T | Trk3 Trunk
E2 | Uplink_SW_202 100/1000T | Trk3 Trunk
E3 | Uplink_SW_202 100/1000T | Trk3 Trunk
E4 | Uplink_SW_202 100/1000T | Trk3 Trunk

Trunk config  switch 2:

Port | Name Type | Group Type
------ + -------------------------------- ---------- + ------ --------
A1 | uplink_SW201 100/1000T | Trk1 Trunk
A2 | uplink_SW201 100/1000T | Trk1 Trunk
A3 | uplink_SW201 100/1000T | Trk1 Trunk
A4 | uplink_SW201 100/1000T | Trk1 Trunk
A23 | uplink_SW201 100/1000T | Trk1 Trunk
A24 | uplink_SW201 100/1000T | Trk1 Trunk
E3 | uplink_SW201 100/1000T | Trk1 Trunk
E4 | uplink_SW201 100/1000T | Trk1 Trunk

Port E3 and E4 ion both switches s the newly added ports

Any good ideas ?

Rgds,

Jesper

7 REPLIES 7
Highlighted
HPE Pro

Re: Ports in trunk flapping

Hi,

What is the message you are seeing in show log when new trunk port flaps?

Can you share 'show interfaces brief' output? 

Also try to reconfigure all ports.

Are these ports part of distibuted trunking?

Thanks!

I am an HPE Employee

Accept or Kudo

Highlighted
Occasional Contributor

Re: Ports in trunk flapping

Hi,

Here is a part of the log from switch 2:

I 06/30/20 09:30:30 00077 ports: port E4 in Trk1 is now off-line
I 06/30/20 09:30:29 00076 ports: port E4 in Trk1 is now on-line
I 06/30/20 09:30:29 00435 ports: port E4 is Blocked by STP
I 06/30/20 09:30:26 00077 ports: port E4 in Trk1 is now off-line
I 06/30/20 09:30:25 00076 ports: port E4 in Trk1 is now on-line
I 06/30/20 09:30:25 00435 ports: port E4 is Blocked by STP
I 06/30/20 09:30:23 00077 ports: port E4 in Trk1 is now off-line
I 06/30/20 09:30:22 00076 ports: port E4 in Trk1 is now on-line
I 06/30/20 09:30:22 00435 ports: port E4 is Blocked by STP
I 06/30/20 09:30:19 00077 ports: port E4 in Trk1 is now off-line
I 06/30/20 09:30:19 00076 ports: port E4 in Trk1 is now on-line
I 06/30/20 09:30:19 00435 ports: port E4 is Blocked by STP
I 06/30/20 09:30:16 00077 ports: port E4 in Trk1 is now off-line
I 06/30/20 09:30:15 00076 ports: port E4 in Trk1 is now on-line
I 06/30/20 09:30:15 00435 ports: port E4 is Blocked by STP
I 06/30/20 09:30:03 00077 ports: port E4 in Trk1 is now off-line
I 06/30/20 09:30:02 00076 ports: port E4 in Trk1 is now on-line
I 06/30/20 09:30:02 00435 ports: port E4 is Blocked by STP

I 06/30/20 09:29:57 00077 ports: port E4 in Trk1 is now off-line
I 06/30/20 09:29:56 00076 ports: port E4 in Trk1 is now on-line
I 06/30/20 09:29:56 00435 ports: port E4 is Blocked by STP
I 06/30/20 09:29:53 00077 ports: port E4 in Trk1 is now off-line
I 06/30/20 09:29:52 00076 ports: port E4 in Trk1 is now on-line

I tried to move trunk ports on switch 2 to another module (F21 and F22)

E3 on switch 1 is connected to F22 on switch 2. This port is up and operational. and is a part of trk1

E4 (Disabled right now) on switch 1 is connected to port F21 on switch 2. When enabling port E34 then it starts to flap.

Below is log from switch 2 when port E4 is enabled:

I 06/30/20 14:49:46 00435 ports: port F22 is Blocked by STP
I 06/30/20 14:48:59 00077 ports: port F21 in Trk1 is now off-line
I 06/30/20 14:48:58 00076 ports: port F21 in Trk1 is now on-line
I 06/30/20 14:48:58 00435 ports: port F21 is Blocked by STP
I 06/30/20 14:48:55 00077 ports: port F21 in Trk1 is now off-line
I 06/30/20 14:48:54 00076 ports: port F21 in Trk1 is now on-line
I 06/30/20 14:48:54 00435 ports: port F21 is Blocked by STP
I 06/30/20 14:48:46 00077 ports: port F21 in Trk1 is now off-line
I 06/30/20 14:48:45 00076 ports: port F21 in Trk1 is now on-line
I 06/30/20 14:48:45 00435 ports: port F21 is Blocked by STP
I 06/30/20 14:48:39 00077 ports: port F21 in Trk1 is now off-line
I 06/30/20 14:48:38 00076 ports: port F21 in Trk1 is now on-line
I 06/30/20 14:48:38 00435 ports: port F21 is Blocked by STP
I 06/30/20 14:48:16 00077 ports: port F21 in Trk1 is now off-line
I 06/30/20 14:48:15 00076 ports: port F21 in Trk1 is now on-line
I 06/30/20 14:48:15 00435 ports: port F21 is Blocked by STP
I 06/30/20 14:48:13 00077 ports: port F21 in Trk1 is now off-line
I 06/30/20 14:48:12 00076 ports: port F21 in Trk1 is now on-line
I 06/30/20 14:48:12 00435 ports: port F21 is Blocked by STP
I 06/30/20 14:48:03 00077 ports: port F21 in Trk1 is now off-line
I 06/30/20 14:48:02 00076 ports: port F21 in Trk1 is now on-line
I 06/30/20 14:48:02 00435 ports: port F21 is Blocked by STP
I 06/30/20 14:47:50 00077 ports: port F21 in Trk1 is now off-line
I 06/30/20 14:47:49 00076 ports: port F21 in Trk1 is now on-line

This trunk is not configured as DT

Rgds,

Jesper

Highlighted
Honored Contributor

Re: Ports in trunk flapping

Can you share with us the outputs of show lacp and show trunks CLI commands executed on your two 5400 switches?

Highlighted
HPE Pro

Re: Ports in trunk flapping

Hi,

If you have spare transceiver then try to replace with existing one or swap with working one and check.

Also please share running software version and detailed inline network topology diagram.

Thanks!

I am an HPE Employee

Accept or Kudo

Highlighted
Honored Contributor

Re: Ports in trunk flapping

Yeah, the more details the OP is able to provide (show flash, show system, show modules, show lldp info remote etc..) the easier could be the troubleshooting...I really hope no SFP Transceivers are involved (give the ports numbering and 100/1000T type listed).

Highlighted
Occasional Contributor

Re: Ports in trunk flapping

Hi,

There is no tranceivers as these connections are cobber cables 

Both switches are running K.16.02.0025.

Rgds,

Jesper

 

Highlighted
HPE Pro

Re: Ports in trunk flapping

Hi,

Sorry I missed, its copper cables.

Can  you try to replace copper cablee with spare cable or swap with other?

I checked the latest software version and this error is not reported.

Are you seeing any other error in show log?

If possible, please upload the complete 'show log' or 'show tech' output in a text file.

Thanks!

 

I am an HPE Employee

Accept or Kudo