System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

mpath not found at boot (RHEL)

 
SOLVED
Go to solution
Highlighted

mpath not found at boot (RHEL)

Hi,

I installed RHEL 5.5 using the "linux mpath" option on a SAN. At that time it had two disks (volume).

I did not yet install the hp hba drivers (qlogic 8GB).

I added the device WWID in the blacklist_exceptions list in /etc/multipath.conf

I added and formatted it using the following:

*fdisk /dev/sdc: new partition that uses all space, and offset to 64 (aligning). */sbin/mkfs.ext3 /dev/sdc

I added it using the following command to mpath: */sbin/multipath

Herafter I can add it with the name /dev/mpath2p1.

The following step was to add it to the /etc/fstab filen, with the following line:

/dev/mapper/mpath2p1 /extradisk ext3 defaults 1 2

This line is nearly the same as the other partitions (besides the name => mpath2p1).

At reboot, after load of the kernel ("Red Hat nash version ...") I get:

fsck.ext3: No such file or directory while trying to open /dev/mapper/mpath2p1 /dev/mapper/mpath2p1: The superblock could not be read or does not describe a correct ext2 filesystem (and not swap or ufs or something else), then the superblock is corrupt, and you might try running e2fsck with alternative superblock: e2fsck -b 8193

**An error occured during the file system check. **Dropping you to a shell: the system will reboot ....

When I login, I cannot see /dev/mapper/mpath2 and mpath2p1. Probably I forgot some mpath configuration?

Thanks!
3 REPLIES 3
Highlighted

Re: mpath not found at boot (RHEL)

Forgot to say: I am using a DL380 G6 and MSA P2000 G3 as SAN.
Highlighted
Honored Contributor
Solution

Re: mpath not found at boot (RHEL)

> /sbin/mkfs.ext3 /dev/sdc

This means the filesystem was created to start at the beginning of the disk, not at the start of the partition.

The fsck.ext3 may produce the error because the filesystem does not begin where fsck.ext3 expects it,

You should have used "/sbin/mkfs.ext3 /dev/sdc1".

Alternatively, the cause of the error might be that /dev/mapper/mpath2p1 device file does not exist yet.

> When I login, I cannot see /dev/mapper/mpath2 and mpath2p1.

Run "multipath". Can you see the devices after that?

Is the multipathd service running?

("service multipathd start" to start it now; "chkconfig multipathd on" to make it start automatically)

The "linux mpath" installation option is for installing the boot & root filesystems on a SAN disk. That means multipathing must be started before mounting the root filesystem, while the system is still running on the initrd. So the multipath.conf file must be copied into the initrd.

If you didn't use "mkinitrd" to re-create your initrd file after making your changes, the old multipath.conf file inside the initrd might confuse things.

I guess the sequence of events might be in this case:

1.) initrd processing starts

2.) system detects SAN disks; udev automatically invokes "multipath"; "multipath" uses old configuration file embedded in the initrd (including the old blacklist setting!)

3.) multipathd starts? (using old configuration in initrd)

4.) root filesystem is mounted; system switches from initrd to the real root filesystem

5.) if multipathd is already running it won't be started again, so it keeps using the old configuration (including the old blacklist setting!)


I'd recommend recreating your initrd file (see "man mkinitrd" for examples) and trying again after that.

MK
MK
Highlighted

Re: mpath not found at boot (RHEL)

> /sbin/mkfs.ext3 /dev/sdc
I think it'a tipo. I reexecuted the formatting to be sure.

The file "dev/mapper/mpath2p1" does at startup not exist. But I can see the disk WWID (so the same disk, without friendly name).

Running multipath gives no difference as multipath is already running (boot on SAN).

Update: maybe reloading could make a difference.

I recreated the initrd file. Now it works!!!

Many thanks!