System Administration
Showing results for 
Search instead for 
Did you mean: 

Problem adding device file above sdz

Go to solution

Problem adding device file above sdz

I have one question. We are running RHEL 4 AS Update 5 on a HP DL585 with two FC1142SR HBAs and we aren't able to add devices (device files) above SDZ. The only thing that helps, is to reboot the server. In two weeks the server will be in a productive state and so we won't be allowed to reboot the server everytime we are adding a LUN or LUNs over the sdz or sdaz range.

First i had problem that the LUNs weren't recognized by the Qlogic driver. I tried the following command

echo scsi-qlascan >/proc/scsi/qla2xxx/1

and after that the LUNs were available. I have also tried the HP_RESCAN script, but it also haven't helped to create the device files.

Furthermore i tried this command

echo "scsi add-single-device A B T L">/proc/scsi/scsi

The device file was not created and now i am not sure if the problem is that we have already reached the /dev/sdz device driver.

Does anyone know where this behaviour is handeld or where i can find these regexp?

Thank you in advance

Esteemed Contributor

Re: Problem adding device file above sdz

Hi && Servus,

you can try to initiate a bus-rescan by using /sys filesystem:

$ ls -la /sys/class/scsi_host/host?/device
compare to lspci output to find host? according your HBA.

now e.g.:
$ echo "- - - " > /sys/class/scsi_host/host1/scan
$ echo "- - - " > /sys/class/scsi_host/host2/scan

now check dmesg for new devies.


Re: Problem adding device file above sdz

Thank you for your help.

I was able to create the device files. But after that i wanted to reproduce the process because I had tried so many things and now i'm at the same point - with a different failure - again ;o)

The LUNs are registered with the OS and i created the sdaa and sdab device files and after that i tried the hp_rescan utility to create the necessitate entries.

Re: Problem adding device file above sdz

So, i was able to reproduce the process and solve the problem with the following commands

echo scsi-qlascan>/proc/scsi/qla2xxx/0
echo scsi-qlascan>/proc/scsi/qla2xxx/1

echo "- - -" > /sys/class/scsi_host/host1/scan
echo "- - -" > /sys/class/scsi_host/host0/scan

The LUNs were found and the device files created.