WAN Routing
cancel
Showing results for 
Search instead for 
Did you mean: 

BGP vpn instance multicast

 
Highlighted
Visitor

BGP vpn instance multicast

Hello guys !

I'm not familiar with HP and I would like some advice from you for this issue.

I have a HPE device which is connected to :

- a Cisco router with a BGP session between them (Let say CISCOBGP)

- a Cisco router with OSPF (Let s say CiscoOSPF)

And, in theory, I could receive multicast stream from the Cisco with OSPF and from the Cisco with BGP (CiscoOSPF is link Master / CiscoBGP is link backup)

With, the OSPF everything is fine, I receive my multicast route and my multicast routing table is filled. But with CiscoBGP, I think, I have a problem with my BGP configuration, but I don't know where cause the multicast routing table is empty.

I'm working in a vpn-instance.

My configuration :

ip vpn-instance WORK
multicast routing vpn-instance WORK

OSPF :

ospf 1 router-id 105.7.0.1 vpn-instance WORK
non-stop-routing
import-route direct cost 5 type 1
import-route static cost 1
filter-policy route-policy IMPORT_WAN import
area 105.7.0.0
network 105.7.70.232 0.0.0.3
#
interface Vlan-interface4
description WAN_JUNIP
ip binding vpn-instance WORK
ip address 105.7.70.234 255.255.255.252
ospf cost 10
ospf network-type p2p
pim sm
#
interface Ten-GigabitEthernet1/0/1
port link-mode bridge
description WAN_JUNIP
port link-type trunk
port trunk permit vlan 4

The multicast routing table is filled. -> display multicast vpn-instance WORK routing-table
BGP :

bgp 60000 instance WORK
router-id 105.7.0.1
timer keepalive 10 hold 30
peer 105.7.70.221 as-number 60000
ip vpn-instance WORK
#
address-family ipv4 unicast
network 105.7.1.0 255.255.255.0
peer 105.7.70.221 enable
#
address-family ipv4 multicast
network 105.7.1.0 255.255.255.0
peer 105.7.70.221 enable
#
interface Ten-GigabitEthernet1/0/2
port link-mode route
description WAN_CISCO
ip address 105.7.70.222 255.255.255.252
pim sm
#

With this configuration, I received the multicast route on the BGP routing table from the CiscoBGP

show bgp instance WORK routing-table ipv4 multicast

Total number of routes: 2

BGP local router ID is 105.7.0.1
Status codes: * - valid, > - best, d - dampened, h - history
s - suppressed, S - stale, i - internal, e - external
a - additional-path
Origin: i - IGP, e - EGP, ? - incomplete

Network NextHop MED LocPrf PrefVal Path/Ogn

* >e 105.100.1.0/24 105.7.70.221
* >e 105.47.2.40/29 105.7.70.221

But, the multicast routing table is empty (if I've deactivate the OSPF connexion before..) :
display multicast vpn-instance WORK routing-table
(*nothing, just my criyng eyes *)

If someone has an idea or see a huge mistake..

Regards,