BladeSystem - General
cancel
Showing results for 
Search instead for 
Did you mean: 

HP BL460c G6 - multiple issues

SOLVED
Go to solution

HP BL460c G6 - multiple issues

background:

  • used to run 2008r2 (hyper-v failover cluster) in a lab enviroment but we needed to test the new server 2012 in order to check future compatibility in hyper-v

 

issue:

  • the blade could not install 2012 and stopped just 10% into the installation (have tried more than once) with the following error in the ILO-log:
    Excessive network delay while communicating with virtual CD-ROM. Virtual media disconnected by: OA ilo~1

 

applied solutions which all failed:

  • update ILO2 from 1.80 to any newer version - fail with error: Firmware upgrade via web page failed
  • trying to boot other OS: 2008r2 - fail, wds/mdt pxe boot - fail, SmartStart - fail, SPP - fail
  • talked to HP support who suggest change in location within the system - no change, everything still fails
  • HP support also suggest minimal configuration and reset of NDROM - yet to be tested

 

starting to think there is an issue not only with the hard drives as suggested in other posts here in the forum, but also if there might be any issues with the build-in broadcom nic?

 

  • the ILO2-bin has been used on other devices in the system (all other BL460 is G1 and allready running newer versions than this G6 have - 1.80 compared to 2+) so there is no issues with that one...
  • image files used on this system have all been used to install all the other blades in the system so no issue there either (also used them from same location so there could not be any issues there)
  • all images from HP have been re-downloaded to new location just to rule out issues

there are currently running both lab and production blades in the system so tamering with it will be an issue, but updates to OA as well as all other ILO2 is something we concider but not have plans for at the moment

 

anyone have any ideas as how to solve this without bringing in a tech from HP (no, we don't have any guarantee or support left with this blade)

9 REPLIES
gregersenj
Honored Contributor

Re: HP BL460c G6 - multiple issues

Here's what I would do.

 

Get the blade BIOS / FW upgraded to latest and greatest. - Using the latest SPP, run it from a USB memorystik, using the KVM cable. Meaning you must be in front of the server, at least for as long as it take you to connnect the cable, and you will have to remove it later.

 

Run a full system diagnostics, at least 1 complete/full loop, if time and patients allow, let it run for a few days.

Do check the suvey for memory errors: recoverable memory error threshold exceeded - this particular failure, I have seen several times. You will see it only in the survey, and the failure LED is flashing. You do not see these failures in the IML nor during system test (Insight Diagnostics), and I have seen this result in unstable servers.

 

Do consider to set the BIOS and possible the ILo to default - Use the BIOS setup utility (F9(BSU)) this will not clear the IML.

If you have any entries in the IML. Fix the problem, and mark all entriesas repaired - do not cler the IML.

The ILo i also recommend to reset, from the F8 prompt - This reset do not affect Accounts AFIK.

 

Sure, you could consider to upgrade the OA as well.

 

Some general issus when using Browser GUI's

Incompatible browsers being used - to old / to new.

Browser cache - Clear the browser cache.

Java Cache (when java is user) - Clear the Java cache.

 

BR

/jag

Re: HP BL460c G6 - multiple issues

All in all a good suggestion though the first two options are not possible as the blade don\t accept to start with any of the images with SPP or SmartStart... when used as mounted images.

As we don't have a any keyboard/screen attached to the blade-system physically the last option will be a bit more difficult to test, as those keys needed to be pressed can't be sent via web/IE ... still working on this last issue though

clearing of cache and such has not solved anything. not even the use of other computers (just in case there would be an issue with my own workstation)

please keep them ideas coming :-)
gregersenj
Honored Contributor

Re: HP BL460c G6 - multiple issues

Use the SUV (Sorry not kvm but suv) cable.

 

The SUV cable you attach in the front of the server - 2 cables came with the enclosure.

Cable got a VGA connector and and 2 USB connectors.

So simply use any VGA monitor, a USB keyboard and mouse. You might be 1 USB port short. You can use a USB hub. Or as I sometimes do, start with the keyboad attached, then remove kb and connect mouse when needed.

You do need a USB connector for the memory stick.

http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c02500121&lang=en&cc=us&taskId=&prodSeriesId=4132949&prodTypeId=3709945

Work for all C-class ProLiant blades.

 

If SPP still hang during boot, remove the FC HBA, if theres 1 installed.

 

BR

/jag

Re: HP BL460c G6 - multiple issues

yeah, we got the SUV-cable but no equipment on location to connect :-)
i am just being lazy for not carrying the stuff over and doing this physically. but i gather this is what needs to be done.

keep you posted...
gregersenj
Honored Contributor

Re: HP BL460c G6 - multiple issues

Good luck.

 

Remember - The monitor need power :)

 

br

/jag

Solution

Re: HP BL460c G6 - multiple issues

so now the blade has been installed and configured as we want it and it runs perfectly...

 

running an ILO2-update so it has the same version as all other blades, which i have found out need to be done in steps..

 

  1. from within the OS run the FW10.10 update which will apply 2.09 to ILO
  2. from OA goto Web Admin and install the 2.15 which will now work just fine

so in order to make this post SOLVED this is what i have found out:

 

  1. the main reason for this all to fail from the begining is the old version of FW (1.80 in this ONE blade and 2.01 in all others)
  2. this old FW made the network mounted images fail due to slow/low capacity thinking it was disconnected from the network. blades using 2.01 didn't fail the installation but it took longer than needed
  3. this also made it impossible to actually use the ilo web admin to update ANY of the previous version (this seem to work from 2.09) to 2.15
  4. this also in turn made it impossible to remotely use any of the HP provided tools to scan for any reason to these issues, so i actually made USB-stick with the files on them and booted physically and then i could update FW in all cases
  5. i have not verified that there actually is some FW-update available for the system itself (it is a c7000 and from what i have seen there is newer versions of the FW but not confirmed myself for our enclosure)
  6. main issue to upgrade enclosure is there are some blades running production enviroment and interupting these will not be an option at this stage

thanks to gregersenj for providing support

i hope this might help someone else, if you need more information don't hesitate and ask me please

gregersenj
Honored Contributor

Re: HP BL460c G6 - multiple issues

Greate, good news :) and you're welcome.

 

FYI. the FW DVD is no longer used. It has been replaced by the SPP. and FW DVD 10.10 is outdated.

 

Latest OA Fw is 3.71. For the interconnect modules, you will hve to check individually.

 

BR

/jag

Oscar A. Perez
Honored Contributor

Re: HP BL460c G6 - multiple issues

The iLO2 firmware update failure issue when using Internet Explorer browsers was fixed in iLO2 version 2.09.  If you have older iLO2 versions, the workaround is to use FireFox instead of IE.

 

 




__________________________________________________
If you feel this was helpful please click the KUDOS! thumb below!
游离世间哥最帅
Super Advisor

Re: HP BL460c G6 - multiple issues

very useful. thanks for share