cancel
Showing results for 
Search instead for 
Did you mean: 

Xserver

Elena Leontieva
Esteemed Contributor

Xserver

Hi,
On RedHat9 the Xserver would not start. The errors are:

Could not init font path element unix/:7100, removing from list!
Fatal server error:
could not open default font 'fixed'

I found that /usr/X11R6/lib/fonts directory structure does not exist. Can I copy it from somewhere?

Any other ideas?

Thanks,
Elena.
11 REPLIES
Vernon Brown_4
Trusted Contributor

Re: Xserver

Hi Elena; You should be able to RPM the fonts from the RH 9 CD.
Steven E. Protter
Exalted Contributor

Re: Xserver

The rpm installer will let you install the fonts and dependencies(there are some).

With all the cd's present and a careful read on the error messages to pick up all the rpms you need.

use the rpm -iv filename.rpm comand. The verbose output has been very helpful to me.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Vitaly Karasik_1
Honored Contributor

Re: Xserver

BTW, is xfs [font server] running?

ps -ef|grep xfs


Regards,
Vitaly
Sergejs Svitnevs
Honored Contributor

Re: Xserver

IMHO The font server is not running, so the required fonts cannot be loaded. If you don't have xfs installed, you need to install it.
Check if your xfs is already installed on your system:
# rpm -qa |grep xfs

Check which port is running on:
# ps ax|grep xfs

Check your XFree86 font path:
# xset -q

Regards,
Sergejs

Elena Leontieva
Esteemed Contributor

Re: Xserver

Hi,

The font server ran at initial install, and after a reboot it broke for some mysterious reason or may be it is something else. At this point a DISPLAY variable is not set.

rpm -qa|grep xfs
XFree86-xfs-4.3.0-2

ps -ef|grep xfs shows that xfs is running

xset -q
xset: unable to open display

Vitaly Karasik_1
Honored Contributor

Re: Xserver

did you try redhat-config-xwindow ?
Sergejs Svitnevs
Honored Contributor

Re: Xserver

You have to install some fonts rpm (if these rpm's don't exist):

XFree86-base-fonts
XFree86-100dpi-fonts
XFree86-75dpi-fonts

Regards,
Sergejs
Umapathy S
Honored Contributor

Re: Xserver

Is there any other messages in the logs under /var/adm.

The font server is having some problems in getting the fonts to work. Somehow the installation didnt do it properly at the first time. Reinstall those rpms again as said by Sergejs.

HTH,
Umapathy
Arise Awake and Stop NOT till the goal is Reached!
Elena Leontieva
Esteemed Contributor

Re: Xserver

OK, let me tell you what is happening. At boot, when it reaches the line "Starting xfs " a login prompt appeares for a second and then the screen goes grey. Eventually a message saying "I cannot start X server. It is likely that it is not set up correctly. Would you like to view the X server output to diagnose the problem?" appears. I said Yes, and it shows the tail of /var/log/XFree86.0.log that I posted in my message. Next it asks "would you like me to try to run the X configuration program?" I said - yes, and entered a password. Finally, it says "I will now try to restart the X server again." OK, and the screen goes grey again then the message "I cannot start .." appears and I say NO this time, so it says "I will disable this X server for now. Restart GDM when it is configured correctly" OK, - and I am at the login prompt.

Thanks,
Elena
Elena Leontieva
Esteemed Contributor

Re: Xserver

Hi,

I tried to reinstall the fonts, but they are already installed. Since I am just playing with Linux, I decided to reinstall it.

Thanks,
Elena.
Sergejs Svitnevs
Honored Contributor

Re: Xserver

1. Check that your graphics card was selected properly. Find out your actual graphics card and modify the /etc/X11/XF86Config , section "Device" option "Driver". Drivers are located at /usr/X11R6/lib/modules/drivers/*_drv.o.

or

2.
# xf86config
answer the questions, save and execute:
# startx `which twm`

Regards,
Sergejs