MSA Storage

cannot login from any interface

 
Brian_Danis
Visitor

cannot login from any interface

Hi Folks,

I have an MSA 2040 to which i cannot login to at all. 

The Web Gui will not load (page not found)

Telnet/SSH/Console direct will get me to a login prompt.  When I enter a valid username/password I get the following error

 

I tried an incvalid username/password and it returns an expected username/password is incorrect.  So I know the credentials i have are good.  What can I do to regain access?

7 REPLIES 7
PrashantS
HPE Pro

Re: cannot login from any interface

Hi,

Have you tried to reboot the MSA. Power cycle it and check it?

But before doing that. Make sure there is IO going to MSA.

Hope you are using correct user name and password. Or contact HP to reset the password. If it reports invalid.


I am a HPE Employee

Accept or Kudo

Brian_Danis
Visitor

Re: cannot login from any interface

I'm pretty confident that the username/password is correct.  I don't get a result of a bad username/password, but do so when I use a known bad password.  I'm assuming you mean to say "make sure there is NO IO going to the MSA" prior to power cycling.  There is a brief window of opportunity to preform a full shutdown of systems during the holiday break.  

Systems are functional now for data usage, so I'm a bit nervous about the potential of the system not booting up correctly after a power cycle.  If anyone else see's this and has any possible alternative (less intrusive) ideas, that would be great.

Without having any access to the system, is the only method of power cycling going to be:

1.  shut down vm's 

2. shut down esx host

3. unplug MSA, wait a couple minutes

reverse to bring it all backup.

Polykdv
Visitor

Re: cannot login from any interface

Hello.

We have a similar problem. I tried turning the controllers off and on, but I can’t connect using any interface (https, telnet, ssh). However, all works, the hosts see the mapped drives.

Error: mccli: error while loading shared libraries: /app/lib/libFWcust.so: cannot read file data: Input/output error

InTech2000
Advisor

Re: cannot login from any interface

Hi,

I have also had similair issues, where I cant log in to the gui with correct creds on controller A.

We have 2 controllers on our MSA, and I managed to login into controller B and restart the management on "A" and it worked.

If you still cant connect, then the controllers are "too busy" to process your request - try logging in when then is less I/O going on maybe?

 

 

tapelibraryfixr
Trusted Contributor

Re: cannot login from any interface

when i cant get the page to load i clear the cookies etc sometimes works

Polykdv
Visitor

Re: cannot login from any interface

Unfortunately, restarting both controllers did not help. Turned off both controllers and then turned them on again - all the same, there is no access via telnet, ssh, web. 

So, now we transfer data to another storage system, and then we will look for a problem.

Polykdv
Visitor

Re: cannot login from any interface

No one has any ideas? I tried to login with username restoredefaults and the serial number of the MSA module as the password, but again error - ERROR - spawn: /3/ connect attempt failed for Command: [/app/defaults/restoreDefaults.sh], errno = 110.