Networking
cancel
Showing results for 
Search instead for 
Did you mean: 

APA failover testing not working

sysad1_1
Advisor

APA failover testing not working

Hi Gurus,

I have just setup an aggregate using my lan1 and lan8 iether NICs. Here's my current setup:

LinkAgg Name : lan900
LinkAgg Status : UP
Station Address : 0x0012799E692A
# Ports in Aggregate : 2
Configuration Mode : MANUAL
Distribution Algorithm : HOT_STANDBY
IP Address : xx.xxx.xx.xx (IP address was not shown intentionally)
Subnet Mask : xxx.xxx.xxx.xxx (Subnet was not shown intentionally)

I tried to test my bond or aggregate and see if failover works by disconnecting the lan cable attached to the either one of my NICs.

When I remove the connection from lan8, my network is still up so no problem with this. However, when I remove the connection from lan1 it is not failing over to lan8.

What configuration that must be done to achieve an automatic failover? Thanks!


4 REPLIES
Matti_Kurkela
Honored Contributor

Re: APA failover testing not working

Please identify your HP-UX version.

In HP-UX 11.31, it is recommended to use nwmgr to configure APA; in older versions, nwmgr does not exist and different commands must be used.

---------

If you're using HP-UX 11.23 or older, please show the output of these commands:

lanadmin -x -i 900
lanadmin -x -y 900

If you built the configuration by editing /etc/rc.config.d/hp_apaportconf, and have not rebooted after that, did you use the correct procedure to activate the new APA configuration?

/sbin/init.d/hpapa start
/sbin/init.d/hplm start

---------

If you're using HP-UX 11.31, please show the output of:

nwmgr -v -c lan900
nwmgr -S apa -I 900 -v

MK
MK
sysad1_1
Advisor

Re: APA failover testing not working

I have not rebooted after setting up my aggregate. My OS is HP-UX 11.11

# hostname
CCBDBPD1
# lanadmin -x -i 900
Link Aggregate PPA # : 900
Link Aggregation Mode : MANUAL
Load Balance Mode : Hot Standby (LB_HOT_STANDBY)
Active Port PPA # : 1
Port(s) ready : 8
Port(s) not ready : NONE

# lanadmin -x -y 900
Hot Standby = ON
Chandrahasa s
Valued Contributor

Re: APA failover testing not working

Hi

Refer below steps,
decide which two lan interface you want to put in apa

both interface should be in same vlan.

verify link between to interface using command

# linkloop -i PrimaryPPANumber StationAddrOfSecondary

# vi /etc/rc.config.d/hp_apaportconf
HP_APAPORT_INTERFACE_NAME[0]=lan0
HP_APAPORT_CONFIG_MODE[0]=LAN_MONITOR

HP_APAPORT_INTERFACE_NAME[1]=lan1
HP_APAPORT_CONFIG_MODE[1]=LAN_MONITOR

vi /etc/rc.config.d/hp_apaconf
HP_APA_DEFAULT_PORT_MODE=LAN_MONITOR

# /sbin/init.d/hplm stop
# /sbin/init.d/hpapa stop
# /sbin/init.d/hpapa start
#lanqueryconf -s

more /etc/lanmon/lanconfig.ascii

verify lan interface entry is proper here

sbin/init.d/hplm start

lanscan -q

it shoudl show like

2
3
900 0 1

For verification you can also do using lanadmin command

lanadmin -r 0

then lanscan -q should show like

900 1

after few seconds it should come back as

900 1 0

chandra
Alzhy
Honored Contributor

Re: APA failover testing not working

LB_HOT_STANDBY requires specific Network Port Settings if I recall. Check with your Network Admin or the fiefdom who controls the Switches.

If you are only after NIC redundancy, follow the above procedure. LAN_MONITOR -- it should work.
Hakuna Matata.