cancel
Showing results for 
Search instead for 
Did you mean: 

Error in CPQNIC.XML

Billy Smith_1
Occasional Visitor

Error in CPQNIC.XML

Hi,

I have a DL585G2 with Teaming enable as follows
Onboard ports 1 + 2 teamed as NFT
NC360T both port teamed NFT

Server runs Windows 2003 R2 x64 with 40G RAM

When I run the teaming utility on the box I get "an error occured due to invalid data in the XML file used by this application" when I click the vlan tab.

When I run cqniccmd /pcpqnic.xml I get an error, extract below
ERROR! An error occurred while parsing the XML configuration data file.
Unexpected XML Element when expecting element:

I have copied another cpqnic.xml file from another box with the same configuraion, we have around 20 and this is the only one that gives me the error.

I ran the cqniccmd /p against the "working" CPQNIC.XML file and it gave the same error.

When I go back to the "working" box and run the command there I still get this error but the vlan tab is OK.

Am I doing something wrong here ?
4 REPLIES
Michael Riglin
Occasional Visitor

Re: Error in CPQNIC.XML

I had the same error, but was able to resolve it. I found nothing to aid me on Google or any of these forums.

Apparently, the XML is fine but it is looking for two registry keys that don't always get created properly during the initial install.

To fix this error message, open REGEDIT and go here:

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002bE10318}\0009]

Add the following DWORD values if one, or both are not already there:

VlanDefaultID
VlanID

Leave the default value of "0" for both.

That's it.
Dennis Berestecki
Occasional Visitor

Re: Error in CPQNIC.XML

This message is for Michael Riglin:

How did you come up with this fix, with no Google or HP help? It seems almost MIRACULOUS...

I was a bit nervous, but I tried it, and it WORKED!
Michael Riglin
Occasional Visitor

Re: Error in CPQNIC.XML

I had this issue with brand new builds on four DL320 G5 servers. All had the teaming configuration, and all were experiencing this error.

A warning in the "System" event log pointed me in the right direction in order to find the missing registry values.

The event log warning showed up only at server startup and is as follows:

<--- snip ---
EventID: 49
Source: CPQTeamMP

Network Team: PROBLEM: This Teaming Miniport-Edge Configuration Parameters section of the Registry is either missing the VlanDefaultID Parameter, or the Parameter is unreadable. Setting value to 0. ACTION: No action is required if the Default behavior is acceptable. Otherwise, reconfigure the VlanDefaultID value.
<--- snip ---

Do you also see this warning on server startup prior to applying the fix?

Lurchi1942
Occasional Advisor

Re: Error in CPQNIC.XML

I have had the same error message when I selecet the HP TeamIcon in the Taskbar.
Solution:
In the device manager under networkcards, I deleted the entry for the Team. After that it wored fine!