Simpler Navigation for Servers and Operating Systems
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
Showing results for 
Search instead for 
Did you mean: 

LSM issue

Kapil Jha
Honored Contributor

LSM issue

I have a issue
Tru64 5.1B PK5
in a volume i have two plexes each having complete disk(day dsk1 and dsk2).
Now VOlume is in ENABLE SYNC state

now what happend is dsk1 has hard error and need to be replaced.
I tried to attach the PLEX(dsk3) but it is giving read error.

For me solution is remove PLEX2(dsk2) recreate it OR put it in CLEAN state and vrestore the backup and change dsk1(after removing plex).

My question is is there any way i can do it with out using backup(what i i do not have backup).

volreattch would help or not????
I am in this small bowl, I wane see the real world......
Kapil Jha
Honored Contributor

Re: LSM issue

Hey any suggestion....i know its smwhat weired....but still i would like to have ur expert suggestion!!!!
I am in this small bowl, I wane see the real world......
Gary Hansford
Frequent Advisor

Re: LSM issue


Are you sure the information you have written is correct ? LSM believes dsk1 is the only good plex that remains in the volume. dsk2 is bad, why are you trying to replace dsk1 when you will stop the volume working ?

Are you using LSM for mirroring? So dsk2 is a mirror for dsk1 ?

If dsk2 is a failed mirror and you want to replace that disk the following sequence can be used: - (for tru64 5.1B)

1. Remove the disk from LSM use:

voldiskadm (option 4)

2. Remove the disk access record and LSM headers:

voldisk rm dsk2

3. Add the new disk into LSM control

voldiskadm (option 1 - use none as disk group)

4. Associate the new disk to disk group

voldisk -g xxxdg -k adddisk dskxx=dskxx

5. Recover the volume

volrecover -g xxxxdg -sb

Hope this all makes sense for you

Kapil Jha
Honored Contributor

Re: LSM issue

thanks Gary for reply

Yes dsk1 and dsk2 are mmirroed.
Let me tell u scene again dsk1 is only plex working in volume,but it has hard errors so disk have to be removed.
i do not understand what second plex ie dsk2(which is fine) is in DETACHED STALE state.
And why it is not attaching???? is there any way to come out of this with out backup.

Anyways problem is resolved took backup(fortunately it was successful) remove and recreate volume and vrestore.

I am in this small bowl, I wane see the real world......
Gary Hansford
Frequent Advisor

Re: LSM issue

Hi Kapil,

An error occured whilst accessing dsk2 (look at your /var/adm/messages to find out what). At this point, LSM believed dsk2 to be failed and so stopped the mirror.

Once LSM believed dsk2 to be bad, it would expect you to replace it (not try and restart it). In order to do this, the 5 steps I listed would guarantee LSM reusing the disk.

The problem you have found is always true of resilience and reporting. If you don't report a failure of a drive / LSM then you'll only find out the problem when the 2nd drive fails (which is a tad late).

I take it you have volwatch running and have set (via rcmgr) VOLWATCH_USERS to the sysadmin email addresses ?? This will ensure LSM notifies you of issues before they become big problems :-)

Glad all is now OK


Jason Buri
Occasional Visitor

Re: LSM issue

I'd like to see if anyone is willing to continue with this thread because I'm having a similar issue. I am going to be forced to follow this through to resolution because our backups are unusable.

The situation:
- Tru64 version 1530 Release V4.0
- System "disk" mirrored via LSM resulting in two plexes called rootvol-01 and rootvol-02
- LSM recently detached rootvol-02 from the volume
- rootvol-01 has a read error that prevents the system disk from being remirrored via typical restoration procedures regardless of what disk I put in as rootvol-02

Possible solutions:
1) I haven't tried this yet, but I assume volrootmir will fail when it gets to the bad blocks just like other attempts to replace the disk. Can anyone confirm or dispute this before I waste time trying it?

2) I'm thinking about pulling the system disk out of the production machine (we'll call this the PS disk - production system disk) and putting it into a spare chasis but not use it as the system boot disk. My plan is to then boot from another disk in the spare chasis and try to copy the PS disk to a third disk in the chasis.

I see that there is a volplex option to force a copy of a plex. Does anyone know if this will force the copy past a fatal read error?

Is anyone willing to hazzard a guess as to what other issues might be involved in making this work? (i.e. getting the the MBR or other things that haven't even crossed my mind.)

3) Any other ideas of options more likely (or at least less unlikely) to succeed ... ?

Thanks in advance,
Kapil Jha
Honored Contributor

Re: LSM issue

NO more replies !!!!
I am in this small bowl, I wane see the real world......