ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

ILO 4 Scripted Media URL

Derek1900
Occasional Contributor

ILO 4 Scripted Media URL

How do i add an iso to virtual media?

ILO 4, ML350 Gen8

 

can the Scripted Media URL be local or is it an internet location?

32 REPLIES
Oscar A. Perez
Honored Contributor

Re: ILO 4 Scripted Media URL

You need a webserver hosting the iso image.  Apache is recommended




__________________________________________________
I work for Hewlett Packard

If you feel this was helpful please click the KUDOS! thumb below!
Derek1900
Occasional Contributor

Re: ILO 4 Scripted Media URL

Oscar, thanks for your reply.

For other that encounter this, i found that i could use the Remote Console and add a local ISO or CD to boot from. It doesn't help for anyone that really does require Scripted Media URL.

 

Ali
HPE Pro

Re: ILO 4 Scripted Media URL

Hi,

 

To use iso image please launch remote console, click on Virtual drive Menu and Select CD/DVD and then select Virtual Image.

 

for detailed step by step instruction please refer to HP Guided Troubleshooting

[broken link removed on 19/04/17 -mod]

 

Launch the guided troubleshooting >> go to setup and installation option >> select HP Integrated Lights Out Virtual Media >> select HP Integrated Lights Out 3 (iLO 3) Virtual Media >> select Using iLO 3 Virtual CD/DVD-ROM..... steps provided remains the same for iLo4

 

Hope this helps,

 

Click on Star Kudos if you think information provided is helpful.

 

regards,

Aftab

I work for HP
Looking for a quick resolution to a technical issue for your HP Enterprise products? HP Support Center Knowledge-base – Just a Click Away!
See Self Help Post for more details
Ali
HPE Pro

Re: ILO 4 Scripted Media URL

Hi,

 

Specific to your question

 

Scripted Media URL is the location of  the virtual media image file on an HTTP server. The image must be located on a web server on the same network as iLO.

example:

protocol://username:password@hostname:port/filename

 

Please refer page 46 of HP iLO 4 Scripting and Command Line Guide for more information.

http://bizsupport1.austin.hp.com/bc/docs/support/SupportManual/c03334058/c03334058.pdf

 

or iLO 4 user guide

http://bizsupport1.austin.hp.com/bc/docs/support/SupportManual/c03334051/c03334051.pdf

 

 

Hope this helps,

 

How to say Thanks, Click on Star Kudos

 

Aftab

 

I work for HP
Looking for a quick resolution to a technical issue for your HP Enterprise products? HP Support Center Knowledge-base – Just a Click Away!
See Self Help Post for more details
anthony11
Regular Advisor

Re: ILO 4 Scripted Media URL



Scripted Media URL is the location of  the virtual media image file on an HTTP server. The image must be located on a web server on the same network as iLO.


 


I read both documents and there's nothing to indicate that the server has to be on the same network -- and the facility would be fairly useless if that were the case.  It *is* claimed however that for some bizarre reason one has to be running on MS Windows (ie., time to set up a VM).

 

          To use iso image please launch remote console, click on Virtual drive Menu and

          Select CD/DVD and then select Virtual Image.

 

The feasibility of this drops considerably when the system and admin are on different sides of an ocean.

 

 

Jimmy Vance
HPE Pro

Re: ILO 4 Scripted Media URL

Correct, The URL for the .ISO doesn't have to be on the same subnet. The iLO and the system hosting the .ISO image just need to be able to communicate.

 

Windows is only a requirement if you want to use the features in the Integrated Remote Console application. You can SSH to iLO and connect the virtual media from the command line. This method is explained in the scritpting and command line guide listed above.




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
anthony11
Regular Advisor

Re: ILO 4 Scripted Media URL

Unfortunately I can't get iLO to even attempt to retrieve the .ISO image.  "iLO experienced an error attempting to insert the media.  Checkt o ensure whether a valid URL was entered".  This is when I stuff a URL into the Connect CD/DVD-ROM -> Scripted Media URL box and click Insert Media.  httpd logs show that it isn't even trying.

 

anthony11
Regular Advisor

Re: ILO 4 Scripted Media URL

Okay, I got past the above, got the URL into a form that ILO would accept, but I find no evidence that ilo is even trying to mount the thing -- httpd logs show no access attempts.

 

Jimmy Vance
HPE Pro

Re: ILO 4 Scripted Media URL

Please provide more information

 

What URL method wasn't working, what did you finally get iLO to accept. examples would be nice.

 

Are you attaching via the IRC application, or over a command line session?

 

Sorry to play 20 questions, but I generally do several installations via this method weekly and only have a failure if I fubar the location as the URL tends to be long for our configuration




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
anthony11
Regular Advisor

Re: ILO 4 Scripted Media URL

I'm not sure why it wasn't initially working for me -- perhaps iLO updates helped, or using an IP address in the URL rather than an FQDN.  Maybe I made a mistake typing and hit a delete -- wouldn't be the first HP software that didn't handle that properly.  In any event it works now.

 

Now, if only I could find a solution to the double-cursor madness...

 

Jimmy Vance
HPE Pro

Re: ILO 4 Scripted Media URL

Anthony, again your pretty vague with your comment. It is hard to offer suggestions without having more information.

 

"Now, if only I could find a solution to the double-cursor madness..."

 

What OS, browser, remote console method, etc are you running on the client

What OS are you running on the server?

 

I just checked a couple my systems using the iLO4 integrated Remote Console appliication and they all have a single cursor.

 

 

 

 




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
anthony11
Regular Advisor

Re: ILO 4 Scripted Media URL


Jimmy Vance wrote:

Anthony, again your pretty vague with your comment. It is hard to offer suggestions without having more information.

 

"Now, if only I could find a solution to the double-cursor madness..."

 

What OS, browser, remote console method, etc are you running on the client

OS is OSX 10.8.2.  The browser is MSIE running in an MSW7 VM, because I've not had good success with iLO (or ILOM) redirected consoles natively.  Remote console method is "IRC" again because it's what works - haven't had good luck with the "Java" one.

 

What OS are you running on the server?

Whatever HP's offline ACU and (discontinued) firmware DVD images boot into, SUSE Linux I think.  At least, I know that the firmware DVD images are SUSE, as I had to re-roll them each time to fix their DHCP bug.

 

I just checked a couple my systems using the iLO4 integrated Remote Console appliication and they all have a single cursor.

 I suspect that you have a different set of variables.

 

https://www.evernote.com/shard/s189/sh/9fb935cf-83c3-41d1-8030-c4dbfa26e536/86cd039f8fac3cea0eaa663ddaa51865

This is a phone snap because I wasn't able to capture the second cursor with Skitch or the builtin facility.  The double cursor problem is frustrating in that only the small black cursor is active.  When I was doing this on an MSWXP VM (iLO 2 and iLO 3 mostly) often I couldn't select a button or other UI element because the white cursor was constrained to the window but the black cursor was active -- the offset of the white prevented the black from being able to reach the corners of the redirected display.

This seems somewhat better with iLO4 on the MSW7 VM, but it's still annoying.  Or maybe it's just better with the hpacuoffline image than with the HP firmware or RHEL install image.

And while I'm here, I need to vent a bit about HP's BIOS / POST design:


o Boot-time utilities require two keystrokes to invoke, eg. ESC 8 for *both* iLO and ORCA.  It can require as many as a dozen cycles to hit the magic split second to get the utility to invoke.  Sun/Oracle systems use a single control character, which is recognized every time. 

o If I can get into the iLO config utility, I can't save any changes because a non-ASCII F10 is expected, which can't be sent over the console.  Function keys are sent as something like ESC[~21, and the ESC is interpreted as exiting without saving. 

o On Gen 8 systems, ORCA can't be entered at all - it ignores ESC 8, hence me having to use the bootable offline ACU.

o On Gen 8 systems (and some G7's) fresh from the factory, the iLO CLI gives a bogus "User not authorized" when one attempts to save any change, eg. configuring an IP/gateway/netmask on the network interface.  Sometimes this clears up if local hands can be found to power-cycle the system.

o The latest batch of Gen 8 systems we've received have the iLO CLI completely disabled from the factory, requiring that someone make a site visit to plug in a legacy monitor and keyboard.

 

 

 

 

 

 

 


 

 

Jimmy Vance
HPE Pro

Re: ILO 4 Scripted Media URL

It appears half of the last post is talking about using the graphical remote console, and the rest is using textcons or serial port iLO access? I'm assuming that's where your using the ESC  sequences?  If you are doing the later, force RBSU to use cli text mode, things go a whole lot smother.

 

As it sounds like you are dealing with a large volume of servers have you given any thought to using the scripting toolkit to automate server setup?

 

I haven't tried running a windows VM under OSX, but I do using KVM. Sometimes I even RDP into a secondary Windows system then start an IRC session with iLO. I will say SLES 11 doesn't track 100%. You can  tweak the xconfig to make it much better (The HP utilities that run a SLES kernel generally track fine as the xconfig has the tweaks)

 

 




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
anthony11
Regular Advisor

Re: ILO 4 Scripted Media URL


Jimmy Vance wrote:

>It appears half of the last post is talking about using the graphical >remote console

That unfortunately is the only way to configure a disk mirror volume onto which to install the OS, once one manages to get an IP address/netmask/gateway configured on the iLO network port (which itself is broken in iLO 4 1.01).

> and the rest is using textcons or serial port iLO access? I'm

>assuming that's where your using the ESC  sequences? 

Yes, the serial port.  I've never managed to get the 'textcons' facility to do anything.

>If you are doing the later, force RBSU to use cli text mode,

>things go a whole lot smother.

 It seems to force that on its own.  I'd rather have ANSI-sequence menus, though, like everyone else who sticks with BIOS uses.  The CLI is a pain when one can't edit command history or cut/paste.

>As it sounds like you are dealing with a large volume of servers

On the order of "dozens".

>have you given any thought to using the scripting toolkit to automate

> server setup?

 From what I can tell that requires booting from media or PXE.  Several problems with that:


1) 25SFF DL380p Gen8 and 10SFF DL360p Gen8 systems have no optical drive

2) If they did, creating a custom boot image for each would be a lot of work

3) Getting a physical DVD or USB drive through customs to someone at the remote site would take weeks, for each system.  And if they were to plug it in, power the server, and nothing happened, what would I do?  According to the document I found regarding this toolkit, console access is still needed.

This scripting toolkit seems like it's still geared toward sites where admins are in the same place as the systems, and a lot of work.  I'd rather just see the bugs fixed in HP's firmware, including the mistaking of servers for desktops.

 

>I haven't tried running a windows VM under OSX, but I do using KVM.

>Sometimes I even RDP into a secondary Windows system then start an

>IRC session with iLO. I will say SLES 11 doesn't track 100%. You can

> tweak the xconfig to make it much better (The HP utilities that run a

>SLES kernel generally track fine as the xconfig has the tweaks)

So, I would re-roll each of HP's .iso images with unspecified tweaks?

 

 


 

 

David_Wilhoit
Occasional Visitor

Re: ILO 4 Scripted Media URL

Well this thread devolved into nothing...

 

to answer the question:

 

  1. Use an existing web server, or install a new web server for the purpose of delivering the ISO files
  2. Create a folder to hold the ISO images
  3. Add ISO file(s)
  4. Enable directory browsing in Web Services. You can do this with the IIS manager if its a Windows web server. If you created a custom folder for the files, enable directory browsing on that folder.
  5. You must add a MIME type for the ISO extension. In Server 2008 IIS, you can do this from the HTTP Headers selection in IIS Manager.
    1. .ISO application/octet-stream
    2. .IMG application/octet-stream
  6. Login to the ILO target server, and open the remote console
  7. At the top of the window, click on Virtual Drives, and then select URL DVD ROM
  8. Input the HTTP path to the image file, including the file name. Click connect and it will mount the drive. Path will resemble "http://hostname or IP/folder/filename.ISO"

 

If your path is correct and available, the ILO target server can be rebooted and it should boot to the ISO file in the CDROM URL path.

cboi
Occasional Visitor

Re: ILO 4 Scripted Media URL

Hi,

 

I tried to use ILO4 Virtual Drives URL facility to install RehHat on my DL380 G8 server, but it fails !

I put in URL field something like : https://<host IP @>/3BL652240057_006_RHEL66.iso, where host IP @, is a Linux server with an Apache server, and 3BL652240057_006_RHEL66.iso, iso customized RedHat file.

The mount image seems to be OK  (how can I check that ?) but when I launch the reboot (Power Switch -> Cold boot), the server does not boot from the iso file ...

For information, both servers are on the same sub-network.

 

Any idea ?

What I made wrong ?

 

Regards

 

cboi

 

 

Jimmy Vance
HPE Pro

Re: ILO 4 Scripted Media URL


cboi wrote:

Hi,

 

I tried to use ILO4 Virtual Drives URL facility to install RehHat on my DL380 G8 server, but it fails !

I put in URL field something like : https://<host IP @>/3BL652240057_006_RHEL66.iso, where host IP @, is a Linux server with an Apache server, and 3BL652240057_006_RHEL66.iso, iso customized RedHat file.

The mount image seems to be OK  (how can I check that ?) but when I launch the reboot (Power Switch -> Cold boot), the server does not boot from the iso file ...

For information, both servers are on the same sub-network.

 

Any idea ?

What I made wrong ?

 

Regards

 

cboi

 

 


Is the URL valid? if you put the URL in a browser, does it attempt to download the file?

 

Since it is a custom image, are you sure the ISO image is bootable?  If you haven't, I'd burn it to media and make sure it boots before looking for other problems.

 

 

 

 




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
cboi
Occasional Visitor

Re: ILO 4 Scripted Media URL

Hi Jimmy,

 

Thanks for the reply.

 

Yes, the URL is valid. If I put it in a web browser, my .iso file is well downloaded.

 

Yes, the custom iso file is bootable. I used it on a burnt DVD also.

 

CBOI

 

 

Oscar A. Perez
Honored Contributor

Re: ILO 4 Scripted Media URL

I noticed you are using HTTPs.  Is HTTPs really needed in your case?  It can significately slow down the ISO transfer speed.  

 

If HTTPs is required, here are few questions:

 

What iLO4 firmware do you have?

 

Is SSLv3 disabled on the webserver?  If so, be sure you have iLO4 2.03 or later.

 

 

Also as a note, older iLO generations (iLO2/iLO3) will use TLS 1.0 to connect to HTTPs servers but, they require the SSL version 2 Client-Hello to be enabled on the webserver for the handshake.




__________________________________________________
I work for Hewlett Packard

If you feel this was helpful please click the KUDOS! thumb below!
cboi
Occasional Visitor

Re: ILO 4 Scripted Media URL

Hi Oscar,

 

I replaced https by http but the issue is the same, the boot attempt fails !

For information, my iLO4 FW release is :

 

License Type iLO 4 Advanced

iLO Firmware Version 1.32 Nov 05 2013

 

Regards,

cboi

Jimmy Vance
HPE Pro

Re: ILO 4 Scripted Media URL

The URL value you put into a browser is exactly the same as your putting into the URL field in ilo?

 

Please post the URL you are using, feel free to replace the actuall IP address or hostname with 0.0.0.0




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
Torxb
Occasional Advisor

Re: ILO 4 Scripted Media URL

I ran into this along time ago, actualy wrote a series of posts on my blog.  At my company we are using these methods to automate most common tasks.

 

http://www.apathis.com/search/label/iLO

 

As far as Name vs IP, I ran into two issues with that.

  1. DNS servers were not specified in network settings, therefore name resoultion no worky.
  2. The name is in another DNS domain so short name was not working.  Server vs server.domain.int
    1. OR Server.domain.int vs server.sub.domain.int
  3. I know this is an old thread, but thought I would give some input for futire google searches.

 

 

anthony11
Regular Advisor

Re: ILO 4 Scripted Media URL

So did you get a URL with any FQDN working?  When last I dealt with iLO I had FQDN problems in multiple places, including virtual media and syslog.

 

 

Torxb
Occasional Advisor

Re: ILO 4 Scripted Media URL

I can use FQDN all day long.  Funny enought another engineer asked me why ISO was not mounting on the ILO via http.  Turns out he just forgot to specify the DNS servers in the nework settings.