ProLiant Servers (ML,DL,SL)

Inventory Error when upgrading firmware

Go to solution
Occasional Visitor

Inventory Error when upgrading firmware

 Hi all, need some help here. been stuck for the past few days.

I have a few gen9 proliant servers that needed to be updated to v2.60. None of them have any os installed, they are all fresh servers

- Downloaded the SPP 2018.06 and key utility

- Converted a thumbdrive into a bootable iso.

Was able to update all but one of the servers. During step 1 of the update, it will perform a baseline and inventory check. The baseline check was successful, however when checking the inventory of the localhost, it failed and showed an inventory error. I could'nt find any more information regarding what caused the error. 


Re: Inventory Error when upgrading firmware


Please refer the following guides:

If you still face issue, do not hesiatate to log a support case with HPE with error screensho and SUM logs



I am an HPE Employee

Accept or Kudo
Occasional Collector

Re: Inventory Error when upgrading firmware

Did you ever get this working? I am facing the same exact issue with the latest SPP and the only uptions the wizard gives me is to "Start over" or to "Reboot". Not sure where to go from here.


Re: Inventory Error when upgrading firmware


While running "launch_hpsum.bat ",  right click and choose run as administrator or run as root user in linux.

else you may get inventory errors.




While I am an HPE Employee, all of my comments (whether noted or not), are my own and are not any official representation of the company

>Accept or Kudo

Occasional Visitor

Re: Inventory Error when upgrading firmware

This is going to sound nuts, but it may work.

We have 24 Proliant HP450s in a Scality Ring.  
12 are local and 12 are across a WAN.
We apply iLO firmware updates every quarter by mounting the firmware .iso as a local drive and booting it.
We do this thru the HTML5 console in the iLO.

For reasons that are unknown to us, the remote servers will regularly fail in the "Inventory of the localhost" stage.
The scale goes to 50% and stops. That's all she wrote.  
Then you either power cycle the box or wait an hour for it to fail on its own,
(At which point it displays "Inventory Error"). Then you can click on "Start Over" (that button is greyed out until you get the "Inventory Error" message).

Now, this is going to sound nuts, 

But it appears that if you keep the mouse in the HTML5 console window,
And keep moving it and clicking (expand and contract the “Inventory Baseline” and the such) while its doing its inventory,
It will make it through the “Inventory” step.

I call this the “Wiggle-Wiggle-DooPah” affect.

If you just let it sit and do it on its own,

Please update as to whether this helps, we won't be doing firmware updates again for a while.

New Member

Re: Inventory Error when upgrading firmware

I was trying to run the 2021-05 SPP on a DL360p Gen10 and it failed three or four times with the Inventory Error.  I found this post and tried moving the mouse but this failed the first time.  I tried it again and it worked the second time.  Maybe this isn't just black magic.

New Member

Re: Inventory Error when upgrading firmware

Yes, it works... if you keep interacting with the interface while it is doing an inventory it finishes all next steps.

New Member

Re: Inventory Error when upgrading firmware

I had to login just to Kudos this.  It hung at about 95% after a few minutes. Left it for an hour with no progress. Restarted and tried it again, kept clicking...done in about 5 minutes total. Unreal.