Storage Software
cancel
Showing results for 
Search instead for 
Did you mean: 

sssu scripting login fails

SOLVED
Go to solution
Denver Osborn
Honored Contributor

sssu scripting login fails

I'm running into a problem with a password change and sssu scripting. It seems that certain special characters used in the password cause things to break via scripting the login commands.

I've tried to escape and surround the password with quotes, but nothing works.

My "commands.txt" file contains a select manager line with username and password. If I run sssu and do an interactive login, it works fine. I've also noticed if the password contains an '(' that it will fail when run from a script.

./sssu "file commands.txt"


SSSU for HP StorageWorks Command View EVA
Version: 6.0
Build: 34
NoSystemSelected> file commands.txt

Error: Password must be specified on SELECT MANAGER
NoSystemSelected>

NoSystemSelected> select sys EVANAME

Error: Command not valid until a manager is selected (SELECT MANAGER)

Has anyone else run into this problem?

Thanks!
-denver
3 REPLIES
cnb
Honored Contributor
Solution

Re: sssu scripting login fails

Hi Denver,

We had the *exact* same issue on that version a couple of years ago. Drove me absolutely nuts trying to make it work with 6.0 and I ended up upgrading SSSU. I don't have access to my systems at the moment and can't remember which version ended up fixing it. I do remember that I tried different SSSU flavors on a TRU64 SAN until I found a combination that worked with the EVA appliance. We may have also upgraded or patched the appliance CV version.

HTH,
Amar_Joshi
Honored Contributor

Re: sssu scripting login fails

Denver,

A simple solution is to reset the password and check it if you can login to SSSU (manually) using the same username & password or not?
cnb
Honored Contributor

Re: sssu scripting login fails

Denver,

Not sure if this is relevant to your issue but I just ran across this thread:

http://forums13.itrc.hp.com/service/forums/questionanswer.do?threadId=1302475

I won't be able to get to my Tru64/EVA system for some time. Sorry I couldn't be of more help.

Rgds,