Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

HP Procurve 2810 & VLANs

SOLVED
Go to solution
Ángel Gutiérrez Rodrígu
Occasional Advisor

HP Procurve 2810 & VLANs

We have a HP Procurve 2810 with three VLANs created:

192.168.0
192.168.2
192.168.4

and we ahve a cumputing cluster in each VLAN. From the control node ( .0.100) we can reach the switch (ping 192.168.0.220) in its own LAN and in the others (ping 192.168.4.220) but we are not able to see any computer in the other VLANs.

The topology is simple:

Switch Control node Computing nodes
192.168.0.220 - 192.168.0.100 - 192.168.0.1
192.168.2.220 - 192.168.2.100 - 192.168.2.1
192.168.4.220 - 192.168.4.100 - 192.168.4.1

Surely we are missing something but we are unable to find what. Any hints?

3 REPLIES
cenk sasmaztin
Honored Contributor
Solution

Re: HP Procurve 2810 & VLANs

procurve 2810 switch only L2 switch

unable routing between vlan

if you want routing between vlan you can purchase 2824 or 2848 switch
cenk

cenk sasmaztin
Honored Contributor

Re: HP Procurve 2810 & VLANs

or you must be use other router device

if you have any router device for example cisco router

must be create 3 sub interface on lan interface
for example

interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.1
description fordownload
encapsulation dot1Q 2 (for vlan 2)
ip address 10.0.10.1 255.255.255.0
ip access-group 10 out
ip nat inside
no snmp trap link-status
!
interface FastEthernet0/0.2
description forguest
bandwidth 1024
encapsulation dot1Q 3 (for vlan 3)
ip address 10.0.11.1 255.255.255.0

and connect switch all vlan tag port

cenk

Ángel Gutiérrez Rodrígu
Occasional Advisor

Re: HP Procurve 2810 & VLANs

Thanks! That was what we guessed from the documentation, that we probably needed a router.