Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Help with VLAN and Routing Issues

CDTi
Occasional Advisor

Help with VLAN and Routing Issues

Hi, been looking around for a bit of advice. To describe the scenario. We have a 5412zl Core switch in one building, linked together by fibre to a 2650-PWR switch in another.

On the core switch all VLAN and routing works perfectly. I have 3 VLAN's as follows:

VLAN 1 - 10.1.0.0/16
VLAN 2 - 10.2.0.0/16
VLAN 3 - 10.3.0.0/16

I have trunked the fibre ports (E3 on the core and port 50 on the edge) into Trk1.

VLAN 2 and 3 are used for the VoIP systems and VLAN 1 is purely for computers and servers (at the moment)

I had this working on the 2650 but then all of a sudden it stopped. Can someone have a blast over the configs and if needed point me right please? Probably something stupid but it has been bugging me all day.

For reference:
MACAD-CORE01 = 5412zl
MACAD-EDGE01 = 2650 PWR

Many thanks!
6 REPLIES
CDTi
Occasional Advisor

Re: Help with VLAN and Routing Issues

Right after a glass of wine and a relax for a bit I think I might of sussed this...

I have spanning tree enabled and obviously this is going to be enabled on all ports at present. So I really need to disable these for all uplinks etc. arn't I?

Also on the 2650 switches I don't need all those IP's on the VLAN's either do I? I only need 1 per switch ideally on the VLAN1 PC and Server VLAN....

Any thoughts appreciated thanks!
OLARU Dan
Trusted Contributor

Re: Help with VLAN and Routing Issues

1. Decide which switch is going to do routing for your intranet, and only assign IP addys to the VLAN interfaces of that one; also routing should be started only on that switch (including default gateway and routing protocol - I don't see the need for two routers in the intranet; maybe you use the routing protocol with the outside). - I would decide in favor of the 5412zl

2. port 50 is "no LACP". Do the same for port E3. See that the speeds, duplex and flow control also match for these two.

3. If you only have one physical link between the switches (port 5412zl#E3 to 2650PWR#50), you don't need trunking: trunking is used for 2+ physical uplinks in the HP world. For Cisco, trunking means 802.1Q. Don't get confused by the definition of trunking HP vs. Cisco.

4. Use 802.1Q tagging only for 2 of the VLANs (the VOIP ones), leave the other one VLAN (the PC one) Untagged for 5412zl#E3 and 2650PWR#50

Should work.

CDTi
Occasional Advisor

Re: Help with VLAN and Routing Issues

Cheers Dan.

Set that now and will see if that works.

Will let you know.

Trunking is done as I will have some more ports to do shortly, just haven't had them yet.

Cheers for the advice!
CDTi
Occasional Advisor

Re: Help with VLAN and Routing Issues

Still no joy...

My Core is working perfectly. All VLANs are working correctly.

Messed around with this 2650PWR switch and it seems to get connection. Then lose it when I don't make any config changes. Tried factory defaults and reconfigure but then it struggles to get connectivity. The only way it gets connectivity again is if I assign IP addresses to each VLAN on the edge. And then it drops. If I set a management address then leave the others as disabled it doesn't even connect.

Really stuck now ready to hoy it ooot the window!
Matt Hobbs
Honored Contributor

Re: Help with VLAN and Routing Issues

Based on your original configurations, they look pretty much right to me.

I would be checking your spanning-tree to make sure it's not blocking ports you don't expect it to be. (show span).

Also, you probably want to make the 5412 the spanning-tree root:

e.g.
spanning-tree priority 1.

If you're still not having any luck, I'd suggest you collect 'show tech' reports from them, draw up a quick network map and open a case with support.
CDTi
Occasional Advisor

Re: Help with VLAN and Routing Issues

Thanks Matt will do.

Glad it isn't something painfully obvious in a way, and shame it isn't.

Might be a faulty switch. Got a spare one going to patch in today so will go from there.

Cheers for your help guys.