System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

how to tell libpng, that zlib is installed

 
SOLVED
Go to solution
Maaz
Valued Contributor

how to tell libpng, that zlib is installed

zlib is installed, as
# cd /usr/src
# tar jxvf zlib-1.2.3.tar.bz2
# cd /usr/src/zlib-1.2.3
# mkdir /usr/local/zlib
# make clean
# ./configure --prefix=/usr/local/zlib
# make
# make install
no prblm but when I tried to install libpng, libpng complains that zlib not found

# tar jxvf libpng-1.2.16.tar.bz2
# cd /usr/local/libpng-1.2.16
# ./configure --prefix=/usr/local/libpng
.
.
.
checking for pow in -lm... yes
checking for zlibVersion in -lz... no
configure: error: zlib not installed
./configure --prefix=/usr/local/libpng
Now help me .. how can I let libpng know, that zlib is installed

Regards
Maaz
5 REPLIES
Rob Leadbeater
Honored Contributor

Re: how to tell libpng, that zlib is installed

Hi,

It might be that configure is falling over on the version of zlib that you're using rather than it not being installed...

What version of Linux are you using ?
Could you not grab binaries (RPMs) of the required libraries... they're fairly standard...

Hope this helps,

Regards,

Rob
Maaz
Valued Contributor

Re: how to tell libpng, that zlib is installed

Thanks for help

>What version of Linux are you using ?
SUSE 10

>Could you not grab binaries (RPMs) of the required libraries... they're fairly
> standard...
I have zlib binary installed
# rpm -q zlib
zlib-1.2.3-15.2
Ivan Krastev
Honored Contributor
Solution

Re: how to tell libpng, that zlib is installed

Use:
--libdir=DIR

if zlibs are compiled or

--includedir=DIR

if source/header files are there.

regards,
ivan
Rob Leadbeater
Honored Contributor

Re: how to tell libpng, that zlib is installed

> I have zlib binary installed
> # rpm -q zlib
> zlib-1.2.3-15.2

As you have the RPM installed you shouldn't have needed to reinstall it from source. That will probably get things confused.

Regards,

Rob
Maaz
Valued Contributor

Re: how to tell libpng, that zlib is installed

the issue resolved, when installed the zlib as
# ./configure
# make
# make install
i.e no arguments/parameters provide to "configure"
then successfully installed libpng ( http://forums1.itrc.hp.com/service/forums/questionanswer.do?threadId=1119589 )

Thanks Ivan Krastev for help.. yes it works too
./configure --prefix=/usr/local/libpng --libdir=/usr/local/zlib

Thanks Rob Leadbeater for help
>As you have the RPM installed you shouldn't have needed to reinstall it from >source. That will probably get things confused.
Yes on a different machine, that have zlib binary installed, without installing zlib from source... i tried to install libpng...a and success

Thanks All
Regards