Web and Unmanaged
cancel
Showing results for 
Search instead for 
Did you mean: 

PS1810 Microserver Gen8

 
gwurb
Occasional Visitor

PS1810 Microserver Gen8

Hi,

I am having issues with PS1810-8G locking up. The network setup is this:

Router -> PS1810 -> Microserver Gen8 with Windows Server 2016

The same PS1810 switch has QNAP 453A connected to it.

PS1810 crashes every single time I do the following after starting Microserver:

1)  Turn on the switch

2) Turn on Microserver

3) Login into Windows Server 2016 user account

4) Connect to QNAP share

5) Go into a second level directory on QNAP share

6) The switch stops working and all other devices coming of the switch loose connectivity

 

When I don't have the Microserver turned on other devices can browse through QNAP shares and there are no problems. I don't know if the issue is PS1810 or Microserver. This has been a problem ever since I purchased the switch but I previously 'solved' it by connecting a second switch to PS1810 and connecting Microserver to that. Today I moved around my equipment and regardless of where the Microserver is connected (directly to PS180 or to a second switch that connects to PS1810) the switch crashes.

Has anyone experienced anything similar? Any idea as to what I could do?

Thanks.

2 REPLIES 2
parnassus
Honored Contributor

Re: PS1810 Microserver Gen8

Hi, it's unusual a Switch crashes due to a bug...especially if it "crashes" only when a very specific host is connected to it.

It's also unclear what do you mean with "crash" (does it reboot automatically? is the network just hanging? all of your connected hosts lose - ping as example - interconnectivity?).

Not knowing exactly your network topology/mapping neither your networked hosts IP assignments nor your Switch ports configuration...do (a) an update your HPE 1810-8G to PS.2.10 (see here), double-check IP addressing (and port/VLAN settings) of all of your connected hosts to verify no overlapping/conflicts are present and then try to understand (Switch side and Host side) why connecting a specific Host to your network segment/switch causes the Switch to hang/crash/reboot (or whatever).

What happens if you DO NOT connect your HPE ProLiant Microserver G10? can you still browse your QNAP's shared folders?

gwurb
Occasional Visitor

Re: PS1810 Microserver Gen8

Hi,

I've attached a network diagram that should be sufficient to describe the current network setup. Devices attached to the switch get their IP addresses from the router. Some of the devices have reserved IP addresses and some are random. 

PS1810 is running PS.2.10 with PS.2.8 as a backup image. All the ports on the switch are on the same VLAN as VLANs are not enabled.

The PS1810 is configured like this:

  • All ports are Auto Link Speed
  • SNTP on
  • DHCP acquired IP address for the switch (specific IP address reserved in the pool so always obtains the same address)
  • Jumbo Frames off
  • No port mirroring
  • Flow control on
  • Green features: Cable Length detect on, Low traffic Idle on, LED intesity on, all else off. I had it all to off and it made no difference
  • Loop protection off
  • STP on with defaults, but no BPDU error recovery. I had this off and it made no difference.
  • Storm and Auto DoS on.
  • Nothing for Trunks
  • Nothing in VLAN 
  • LLDP is defaults
  • Anything that I missed?

When I write crash I mean the following occurs:

  • Switch management interface can not be reached
  • I can not ping other devices attached to the switch (for example using Windows 10 PC to ping QNAP NAS). This applies for all the hosts connected to the switch so I don't think its port specific
  • I can not use other services like SMB for devices attached to the switch (for example after the switch 'crashes' Windows 10 PC can not connect to QNAP shares)
  • There is no reboot. For the switch to start passing traffic I pull the plug, wait, plug it back in

If I do not start up the Microserver G8 the PS1810 works and other devices continue to have access to each other. Other devices on the other ports of the router continue to have ping access to PS1810 connected devices, and have access to QNAP shares.

I have tried connecting NIC 1 and NIC 2 of the Microserver to the PS1810 and seeing if it made any difference. No difference having either NIC connected. I have not tried having only ILO connected to the PS1810.

I have not tried disconnecting QNAP and trying to mount Windows 10 shares on Windows Server 2016 (Microserver Gen 8). That may be worth doing but issue will still remain that a specific host (HP Microserver Gen8) causes the HP PS1810 switch to crash. Its even more odd to me as the two are designed to work in unison. 

The only solution that I have found so changing the network layout. If you look at my attached diagram and on it disconnect the Microserver Gen8 and QNAP from PS1810, then connect them to the unmanaged switch. In that scenario, where the layer 2 connection between Microserver Gen8 and QNAP is across another switch (a switch that is connected to PS1810) there is no crashing of PS1810.