BladeSystem - General
Showing results for 
Search instead for 
Did you mean: 

Re: VC Module query

Go to solution
New Member

VC Module query

This is my setup:
c7000 enclosure
1/10Gb VC modules in bays 1, 2, 6 & 8 (firmware 2.34)
I have just upgraded the modules and switched to fibre instead of copper, I have one NIC not working on all blades (although it says it is connected). I have noticed that if I look at the interconnects in Virtual connect mgr the ports are listed from d16 to d1 instead of d1 to d16. also the Stacking links connected to/from are reversed. Has anyone else seen this before?
Your help will be much appreciated!
Honored Contributor

Re: VC Module query

Hi Bob,
Can you be more specific about what you upgraded? (software, hardware).

And what specifically do you mean when you say you switched from Fibre to Copper? Do you mean from "1/10G F Ethernet" to "1/10G Ethernet".

Reason for asking: I have seen a similar problem but it involved upgrading from 1/10G VC Ethernet to Flex10 VC Ethernet. The problem was actually caused when I tried to re-import the 1/10 configuration file into the Flex10. It turns out they are incompatible, and the Flex10's had to be reconfigured from scratch (not too difficult to script (but VC assigned MAC's and WWID's complicate things))

Let us know.

New Member

Re: VC Module query

Hi Dave,

Wasn't me that did the upgrade but here's what the fella sent me (at the bottom of this text). I'm comparing the one he upgraded to existing ones that work fine. Seems odd that if I look under the "Hardware Overview" in VC manager the port mappings for the Interconnect modules don't match thiose of the device bays.

Product Name HP 1/10Gb VC-Enet Module ManagementPart Number 399593-B22 Spare Part Number 399725-001 Serial Number Firmware Version 2.33

New Config

Product Name HP 1/10Gb-F VC-Enet Module Management
Part Number 447047-B21 Spare Part Number 447103-001 Serial Number Firmware Versions tried 2.33, 2.34, 3.01
Honored Contributor

Re: VC Module query

Well Bob,
I have never done this particular upgrade, however it is possible that you are seeing something similar to what I saw. In order to go deeper, you will need to describe exactly how the upgrade was done.

Also I just noticed that you said that your VC modules are in Bays 1, 2, 6 & 8. Is this true??

The point is that these modules are normally installed in horizontal pairs, so 5 with 6, and/or 7 with 8.

If you only put the modules in the right hand (or left hand) bays, then only half of the ports on any Mezz cards installed, will be usable. The other half of the ports will be unusable. So if you have a 2-port card installed on a MEZZ, only 1 will be usable, if it is a 4-port card, then only 2 will be usable.

Normally, a single module would be installed in the left hand bay, and if there was a second module it would go in the right hand bay.

In your case, 1 & 2 are correct, these bays are used by the Onboard NICS.

Assuming you are using halfheight blades, the module in Bay 6 would only be accessible through port 2 of the Card in MEZZ slot 2, and the module in Bay 8 would only be accessible through port 4 of the card in MEZZ slot 2 (and then only if it was a 4-port NIC card in the MEZZ slot). If it is a 2-port card, then nothing in your halfheight blade will map to Bay 8.

If you have full height blades, then the cards in MEZZ3 will map to Bay 8.

New Member

Re: VC Module query

Thanks - sorry I actually meant bays 1, 2, 5 & 6!
In Virtual Connect manager > Hardware Overview > Interconnect Bays > for the Server Port Information on each VC bay the ports numbered d16 - d1 in that order. I think they should be displayed d1 to d16. They also do not match the ports the device bays say they are mapped to. e.g. device bay 1 says it is mapped to interconnect bay 1 ports 9 & 1 but the interconnect bay 1 says device bay 1 is mapped to ports 8 & 16. I have attached a screenshot showing this - could this be the issue?
Honored Contributor

Re: VC Module query

This certainly looks a lot like what we saw during our upgrade to Flex10. When we did our upgrade we followed the book. Basically,

1. Backup VC Config.
2. Swap out modules.
3. Create new VC Domain.
4. Restore VC Config from backup.

We found that everything was OK up to item 3.
When we did item 4, i.e. restore config, all of the mappings changed to similar to yours.

It is interesting to look at the IC Bay 1 connections and see that Ports d2, d9 and d10 show "Linked" even though there appears to be no "physical server" present.

IMHO, this is clearly an issue for HP support. (Although you could probably get past it if you were prepared to build the domain from scratch, i.e. do step 4 manually)