BladeSystem Virtual Connect
Showing results for 
Search instead for 
Did you mean: 

Virtual Connect Command Line Scripting

Trusted Contributor

Virtual Connect Command Line Scripting

Reginald was looking for some VC scripting help:




                Working with a customer in putting together some VC scripting to build out their enclosures unattended. I notice that the following command aborts even though it is set to expanded.


                - VC scripting command “set enet-vlan VlanCapacity=Expanded”


Even though we’re supplying a response to the variable, it still prompts for a response from the user. If I remove the command from the file it will execute all of the commands without an error. In doing so, I can set this value either through the GUI or CLI. Can someone explain as to why it is looking from a response from the user when I’m supplying a response?




Reply from Dave:

I use VC scripting with a lot of site now. The key is to add ‘yes’ to the next line:


VC scripting command “set enet-vlan VlanCapacity=Expanded”


### Next line


This has worked for me.

If you do not add the yes, it will pick up the first command of the next line and then the next line and so on.


And input from Steve:

 Actually, use the –quiet switch…


set enet-vlan -quiet vlancapacity=expanded


Page 25 of the FF CB -


Response from Reginald:

Thanks to all that responded! Both suggestions worked.




Any other comments?