Comware Based
1748019 Members
4589 Online
108757 Solutions
New Discussion юеВ

Re: 3COM Inter-VLAN routing

 
screwbash
New Member

3COM Inter-VLAN routing

Hi , I am pasting my current config below. I have just configured two 3com switches but i cannot get the VLAN's to communicate with each other. I have the servers on one and the clients on the other. Please see the configuration below. Can you please tell me what i am doing wrong. Thanks





sysname switch12fl1



system-view

acl number 2000 match-order config

rule 1 permit source 192.168.10.1 0

rule 2 permit source 192.168.20.1 0

rule 3 permit source 10.100.200.1 0

rule 4 deny source any



user-interface aux 0

authentication-mode none

user privilege level 2

history-command max-size 20

idle-timeout 6 0

screen-length 30

speed 19200

protocol inbound telnet



user-interface vty 0 4

acl 2000 inbound



ip http acl 2000



acl number 3000

rule 1 deny ip source 192.168.10.0 255.255.255.0 destination 10.100.200.0 255.255.255.0

rule 2 deny ip source 192.168.20.0 255.255.255.0 destination 10.100.200.0 255.255.255.0

rule 3 deny ip source 10.100.200.0 255.255.255.0 destination 192.168.10.0 255.255.255.0

rule 3 deny ip source 10.100.200.0 255.255.255.0 destination 192.168.20.0 255.255.255.0



-------------------------------------



vlan 10

vlan 20





interface Vlan-interface 10

ip address 192.168.10.80 255.255.255.0



interface Vlan-interface 20

ip address 192.168.20.80 255.255.255.0

ip route-static 10.100.200.0 255.255.255.0 192.168.20.81



vlan 10

port GigabitEthernet1/0/1



vlan 20

port GigabitEthernet1/0/2



interface GigabitEthernet 1/0/1

port access vlan 10



Interface GigabitEthernet 1/0/2

port link-type trunk

port trunk permit vlan 10 20 30







---------------------------------------------------

sysname switch48fl1



system-view

acl number 2000 match-order config

rule 1 permit source 192.168.10.1 0

rule 2 permit source 192.168.20.1 0

rule 3 permit source 10.100.200.1 0

rule 4 deny source any









vlan 20

vlan 30







interface Vlan-interface 20

ip address 192.168.20.81 255.255.255.0

ip route-static 192.168.10.0 255.255.255.0 192.168.20.80



interface Vlan-interface 30

ip address 10.100.200.3 255.255.255.0





vlan 20

port GigabitEthernet1/0/33

vlan 30

port GigabitEthernet1/0/34





interface GigabitEthernet 1/0/34

port access vlan 30



Interface GigabitEthernet 1/0/33

port link-type trunk

port trunk permit vlan 10 20 30



4 REPLIES 4
cheehoong
Occasional Advisor

Re: 3COM Inter-VLAN routing

4200 and 4800 are ready for intal_VLAN

i think u miss to build up the trunk port for each VLAN

richardkok
Frequent Advisor

Re: 3COM Inter-VLAN routing

You have a routing problem anda double ip address

this should work:



VLAN1 = management VLAN

VLAN10 = Clients

VLAN20 = Servers

Switches are connected through ports 1/0/2



--------------------------------

SYSNAME SWITCH1



vlan 1

vlan 10



interface Vlan-interface 1

ip address 192.168.1.1 255.255.255.0



interface Vlan-interface 10

ip address 192.168.10.1 255.255.255.0



interface GigabitEthernet 1/0/1

port access vlan 10

flow-control

broadcast-suppression pps 3000



Interface GigabitEthernet 1/0/2

port link-type trunk

port trunk permit vlan 1

flow-control

broadcast-suppression pps 3000



ip route-static 0.0.0.0 0.0.0.0 IPADDRESSINTERNETROUTER preference 60

ip route-static 192.168.20.0 255.255.255.0 192.168.1.2 preference 20



---------------------------------------------------

SYSNAME SWITCH2



vlan 1

vlan 20



interface Vlan-interface 1

ip address 192.168.1.2 255.255.255.0



interface Vlan-interface 20

ip address 192.168.20.1 255.255.255.0



interface GigabitEthernet 1/0/1

port access vlan 20

flow-control

broadcast-suppression pps 3000



Interface GigabitEthernet 1/0/2

port link-type trunk

port trunk permit vlan 1

flow-control

broadcast-suppression pps 3000



ip route-static 0.0.0.0 0.0.0.0 IPADDRESSINTERNETROUTER preference 60

ip route-static 192.168.10.0 255.255.255.0 192.168.1.1 preference 20

---------------------------------------------------





regards

r.

screwbash
New Member

Re: 3COM Inter-VLAN routing

Hi , I am pasting my current config below. I have just configured two 3com switches but i cannot get the VLAN's to communicate with each other. I have the servers on one and the clients on the other. Please see the configuration below. Can you please tell me what i am doing wrong. Thanks





sysname switch12fl1



system-view

acl number 2000 match-order config

rule 1 permit source 192.168.10.1 0

rule 2 permit source 192.168.20.1 0

rule 3 permit source 10.100.200.1 0

rule 4 deny source any



user-interface aux 0

authentication-mode none

user privilege level 2

history-command max-size 20

idle-timeout 6 0

screen-length 30

speed 19200

protocol inbound telnet



user-interface vty 0 4

acl 2000 inbound



ip http acl 2000



acl number 3000

rule 1 deny ip source 192.168.10.0 255.255.255.0 destination 10.100.200.0 255.255.255.0

rule 2 deny ip source 192.168.20.0 255.255.255.0 destination 10.100.200.0 255.255.255.0

rule 3 deny ip source 10.100.200.0 255.255.255.0 destination 192.168.10.0 255.255.255.0

rule 3 deny ip source 10.100.200.0 255.255.255.0 destination 192.168.20.0 255.255.255.0



-------------------------------------



vlan 10

vlan 20





interface Vlan-interface 10

ip address 192.168.10.80 255.255.255.0



interface Vlan-interface 20

ip address 192.168.20.80 255.255.255.0

ip route-static 10.100.200.0 255.255.255.0 192.168.20.81



vlan 10

port GigabitEthernet1/0/1



vlan 20

port GigabitEthernet1/0/2



interface GigabitEthernet 1/0/1

port access vlan 10



Interface GigabitEthernet 1/0/2

port link-type trunk

port trunk permit vlan 10 20 30







---------------------------------------------------

sysname switch48fl1



system-view

acl number 2000 match-order config

rule 1 permit source 192.168.10.1 0

rule 2 permit source 192.168.20.1 0

rule 3 permit source 10.100.200.1 0

rule 4 deny source any









vlan 20

vlan 30







interface Vlan-interface 20

ip address 192.168.20.81 255.255.255.0

ip route-static 192.168.10.0 255.255.255.0 192.168.20.80



interface Vlan-interface 30

ip address 10.100.200.3 255.255.255.0





vlan 20

port GigabitEthernet1/0/33

vlan 30

port GigabitEthernet1/0/34





interface GigabitEthernet 1/0/34

port access vlan 30



Interface GigabitEthernet 1/0/33

port link-type trunk

port trunk permit vlan 10 20 30



cheehoong
Occasional Advisor

Re: 3COM Inter-VLAN routing

what model you are using ?