HPE 9000 and HPE e3000 Servers
Showing results for 
Search instead for 
Did you mean: 

Re: Connect into GSP from a shell

Go to solution
Super Advisor

Connect into GSP from a shell


Im in the UK and the server I wish to connect to is in Singapore. I would like to check the GSP from a shell, I have tried information in the following post but believe the tty1p0 file may be wrong

The server in question is an A400.

My device files show as below from ioscan

tty 0 0/0/4/1 asio0 CLAIMED INTERFACE PCI Serial (103c1048)
/dev/GSPdiag1 /dev/mux0 /dev/tty0p3
/dev/GSPdiag2 /dev/tty0p0 /dev/tty0p4
/dev/diag/mux0 /dev/tty0p2

Argh ye land lovers !
Honored Contributor

Re: Connect into GSP from a shell

The information in the earlier post refers to an old GSP hardware version (A6696A). The older version has hardware path 0/0/4/0 as the console path with the /dev/tty0p* devices; the newer GSP (A6696B or the one integrated in A400/A500/rp24xx serias) has 0/0/4/1.

Looks like the trick described in the earlier post does not work on newer GSPs. I tried it on L-class hardware and some rp2470s: on old L-classes with A6696A GSP it works, on rp2470s and L-classes with A6696B GSP it does not work.

With A6696A GSP, the GSP help overview (HE OV, 11th page) gives the same information as in the post you mentioned. Newer GSPs also have the "INTERNAL PORT HELP" chapter, but it says only "The Internal Port has been obsoleted."

I'm afraid you're out of luck.

The internal port was a method to reset the GSP passwords in case they were lost. The newer GSPs have a different method for that purpose. It requires you to access the physical "local" console, so it is probably more secure.
Super Advisor

Re: Connect into GSP from a shell

Thanks, that has answered my question
Argh ye land lovers !