HPE SimpliVity
cancel
Showing results for 
Search instead for 
Did you mean: 

Re: OmniStack 4.0.0 Smart Array Controller firmware

 
SOLVED
Go to solution
Highlighted
Advisor

OmniStack 4.0.0 Smart Array Controller firmware

Hello,

We are running HPE Simplivity 380 G10 nodes and are currently on our way upgrading from Omnistack 3.7.9 => 4.0.0.

A few days ago I received an email from HPE saying that HPE Simplivity 380 G9 and G10 nodes running HPE Smart Array SR Gen10 Controller Firmware version 1.98 and 1.99 are susceptible to "A potential data inconsistency during initial configuration and operation of a volume configured in RAID 5/6/50/60 Fault Tolerant Mode", and strongly recommended we upgrade ASAP to HPE Smart Array SR Gen10 Controller Firmware Version 2.65.

Link here: https://support.hpe.com/hpesc/public/docDisplay?docId=emr_na-a00097210en_us

Shotly thereafter, we received another e-mail saying "HPE does not recommend independently updating to Firmware Versions Newer than 1.99 for HPE Smart Array SR Gen10 Controllers on HPE SimpliVity Gen10 systems." and that "Due to the HPE SimpliVity product architecture, the Smart Array Gen10 Controller versions included in the HPE OmniStack bundle will continue to be the best option for HPE SimpliVity Gen10 products."

Link here: https://support.hpe.com/hpesc/public/docDisplay?docId=emr_na-a00097566en_us

We are currently running Omnistack 3.7.9, with firmware SVTSP-2019_0315.04.iso which is using Smart Array controller version 1.66. Is it still recommended to upgrade to Omnistack 4.0.0, seeing as that currently only seems to support Smart Array controller version 1.98 and 1.99? Could you reason it is actually better to stay at Omnistack 3.7.9 and avoid the potential storage issues announced in the bulletin?

 

Best regards,

Gustav andersson

12 REPLIES 12
Highlighted
HPE Pro

Re: OmniStack 4.0.0 Smart Array Controller firmware

Your logic seems sounds but if you read the release notes for 1.99 1.98 how many issues do these resolve from the 1.66 version which you leave yourself potentially open too.

On  the other hand 3.7.9 is relatively new and stable so you could wait until a later FW version  is added to the compatibility matrix.

 

 

 


I am an HPE employee
Accept or Kudo
Highlighted
Advisor

Re: OmniStack 4.0.0 Smart Array Controller firmware

Thanks for your reply.

I am having trouble finding what issues are fixed between Storage controller v1.66 and v1.98/v1.99. Could you help me out there? The release notes under the "Release Notes" tab on the download page of SVTSP-2019_0604.03.iso do not provide many details. Link here: https://support.hpe.com/hpsc/swd/public/detail?swItemId=MTX-e228c310b3a4414ba85c879553#tab4

I guess it all depends on the risk of occurrence of the fault and the severity of the fault if it's worth upgrading or not. Since a special bulletin was sent out regarding v1.98 and v1.99, I can only assume it is quite serious.

 

Best regards,

Gustav Andersson

Highlighted
Advisor

Re: OmniStack 4.0.0 Smart Array Controller firmware

Hello!

HPE Omnistack 4.0.1 was just released yesterday, but the new firmware released still contains the same Gen10 HPE Smart Array version (1.99) as before.

What does Simplivity recommend us do here? I was recommended in this thread to wait for the next release after 4.0.0, and now it's here, but we are faced with the same choice. Do we stick running 3.7.9 which is running Gen10 HPE Smart Array version 1.66 which doesn't have the issues discussed in this thread, or do we upgrade to 4.0.1 which does have the issue?

I am having a really hard time making an informed choice. I would greatly appreciate some advice. 

/Gustav Andersson

Highlighted
HPE Pro
Solution

Re: OmniStack 4.0.0 Smart Array Controller firmware

Hi Gustav

Sorry if my previous reply was a bit ambiguous the FW i was talking about was the 2.65 for the smart array controller this is not directly tied into the Simplivity software version eg 4.0. 4.1 ect.As of this time the 2.65 FW is undergoing qualification with engineering.

I expect that once qualified a number of builds will be supported both the newest and a number of  builds 3.7.9 included.I dont have an ETA as to when they will complete qualification.The testing is pretty rigorous and multiply that by multiple versions its not as quick as a standalone fw upgrade on a non simplivity node.

Controllers on HPE SimpliVity Gen10 systems." and that "Due to the HPE SimpliVity product architecture, the Smart Array Gen10 Controller versions included in the HPE OmniStack bundle will continue to be the best option for HPE SimpliVity Gen10 products."

You can choose not to upgrade and expose yourself to potential issues around this Smart Array FW issue , but you expose yourself to other potential issues resolved in not doing so.If its a major concern for you,and you are not hitting any other issues  resolved in a later release of Simplivity or VMware (qualified on Simplivity) there is no harm in staying where you are and waiting for the 2.65 Fw to be qualified.

 

 

 


I am an HPE employee
Accept or Kudo
Highlighted
Advisor

Re: OmniStack 4.0.0 Smart Array Controller firmware

Hello,

Any update on when firmware for v2.65 for the smart array controller is going to be released for Simplivity?

 

/Gustav

Highlighted
HPE Pro

Re: OmniStack 4.0.0 Smart Array Controller firmware

@guan8 

Thanks for your query. No definitive ETA on this right now, but I will update this thread as more details/specifics are available.

Thanks,

DeclanOR

Accept or Kudo



I am an HPE Employee
Highlighted
HPE Pro

Re: OmniStack 4.0.0 Smart Array Controller firmware

Hi @guan8 

Just wanted to update the thread to inform you that Smart Array FW 2.65 has been qualified for the upcoming 4.1.0 release expected to be generally available at the end of June.

Thanks,

DeclanOR

Accept or Kudo



I am an HPE Employee
Advisor

Re: OmniStack 4.0.0 Smart Array Controller firmware

That's awesome news! Thanks for the update!

/Gustav
Highlighted
HPE Pro

Re: OmniStack 4.0.0 Smart Array Controller firmware

Hi @guan8 

No problem. Thanks for your patience! 

Best regards,

DeclanOR

Accept or Kudo



I am an HPE Employee