ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Corrupt SPS on ML350 Gen10 - cannot install newer version

 
Highlighted
Occasional Contributor

Corrupt SPS on ML350 Gen10 - cannot install newer version

Hi everyone.  I have a ML350 Gen 10.  Yesterday I did a System ROM upgrade (to 2.34) which seemed to go fine, rebooted, during post got the message "3019-Server Platform Services Firmware in Recovery Mode. SPS firmware image is corrupted. -System Halted!"

Now from reading other posts it seems the correct (and obvious) course of action is to update the SPS.  This is where I have the issue:

Using ILO 5 (2.16)

Uploaded SPS 4.1.4 to the iLO repository.

Created the install job in the Installation Queue.

Done the reboot, the same thing as above happens.  Basically in a loop.  The install job never actually starts.  I've reset, cold powered, even pulled the power cords over night hoping that the next time it powers up, the job will start, but it never does.

I've even go through with the SPP disc, that did the inventory and uploaded its own files and created its own jobs but the same thing happens, after the reboot the install never begins to run.  Kinda worried now I've bricked a multi-thousand dollar server...

Any advice on how to get this SPS updated would be welcome.  For what it's worth, the currently installed version is 4.0.3 and the firmware intergrity check does show it's corrupt.

Help!!!

Thanks!

5 REPLIES 5
Highlighted
HPE Pro

Re: Corrupt SPS on ML350 Gen10 - cannot install newer version

Hi
Have you referred to this advisory?
https://support.hpe.com/hpesc/public/docDisplay?docLocale=en_US&docId=a00100177en_us
You need to download the OS independent SPS firmware Component and use the .flash file to update the firmware from ILO


Latest Firmware download link: https://support.hpe.com/hpsc/swd/public/detail?swItemId=MTX_8d1148a85dde488ebeec6d6aa4

Version: 04.01.04.381(8 Jun 2020)
I am a HPE Employee

Accept or Kudo

Highlighted
Occasional Contributor

Re: Corrupt SPS on ML350 Gen10 - cannot install newer version

I can't find an actual .flash file - I download the fwpkg file, if I extract that I have a .bin file... I've uploaded the .bin to the iLO repository and then added the install to the queue.  While powered off it did actually start installing (more than I've ever got it to do before) - it made it to about 75% then aborted:

 

Firmware Update
The last attempt to update or upload firmware was not successful. Make sure you are using a valid, signed flash file and try again. If you are attempting to install a component, first upload it to the iLO Repository then add it to the Installation Queue.
 
Clicking on the job in the queue:
Name: Update-SPS
Command: Apply update
File name: SPSGen10_04.01.04.381.signed.bin
State: Exception
Result: The update failed with a component specific error. Retry the update after fixing the component error.
Installable by: iLO
Maintenance Window: None specified
Start Time: N/A
Expiration: Never
Update Recovery Set? No
Created by user with Recovery Set privilege? Yes
Highlighted
Occasional Contributor

Re: Corrupt SPS on ML350 Gen10 - cannot install newer version

Well I appear to of fixed it - I flashed back the original version that was on.  That seems to of resolved the corruption and the server is now booting the OS.

I'll try updating the SPS again later.

That was way more complicated than it needed to be...

Highlighted
HPE Pro

Re: Corrupt SPS on ML350 Gen10 - cannot install newer version

Great. 

I have tried in my lab and I used the SPSGen10_04.01.04.381.signed.bin file. 

Added this file to ILO repository -> added to installation queue -> powered off the server -> Install the package. 

It was successful. Did not give any error and took less time. Not sure what went wrong when you flashed. 

Its good that the isuse is resolved. 

I am a HPE Employee

Accept or Kudo

Highlighted
Acclaimed Contributor

Re: Corrupt SPS on ML350 Gen10 - cannot install newer version

This version is now REMOVED from the webpage!

https://support.hpe.com/hpsc/swd/public/detail?swItemId=MTX-8d1148a85dde488ebeec6d6aa4


Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!