ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

HP 360 G8 iLo 4and alertmail

 
Highlighted
Occasional Advisor

HP 360 G8 iLo 4and alertmail

Hi all,

sorry for my englisch . I have trouble with Alertmail in the iLo . I have set snmt , which  working ok , and I want enable alertmail from iLO . But I set thos but after i try send test mail the iLo say message send but in the target mail is nonemail :smileysad:

some solution ?

thanx

16 REPLIES 16
Highlighted
Valued Contributor

Re: HP 360 G8 iLo 4and alertmail

My setup works with this settings:

[X] Enable ILO Alert Mail

email adres: <your email adres>  for example: x.y@test.com

Sender Domain: <test.com>

SMTP Port:<25>

SMTPServer:<The server responsible for SMTP traffic on your LAN, for example: SMTP.test.com>

 

When that doesn.t work, maybe there's something wrong with your DHCP/DNS setup.

PZ
Highlighted
Honored Contributor

Re: HP 360 G8 iLo 4and alertmail

What iLO4 firmware version do you have?

 

I know there was an issue with iLO resolving the SNMP server's DNS name.  Try using the IP address instead. 




__________________________________________________
If you feel this was helpful please click the KUDOS! thumb below!
Highlighted
Occasional Advisor

Re: HP 360 G8 iLo 4and alertmail

thank you for answer . the version firmware is 1.32

thanx

Highlighted
Occasional Advisor

Re: HP 360 G8 iLo 4and alertmail

HI all,

victory ;))) the trouble is in the general domain name . I this value have empty . After I fill this the alertmail send . Why I must have this parametr fill ??? ALert mail is send to ip adress . And If is required why the ilo permit save without it ??? arghhhh ...

:)

Highlighted
Occasional Contributor

Re: HP 360 G8 iLo 4and alertmail

Would you mind telling me how u set the  so-called "general domain name"?

 

Server lies on different domain (e.g. domain2.com)

My setting:

 

[X] Enable ILO Alert Mail

email adres: ABC@domain1.com

Sender Domain: domain1.com

SMTP Port:<25>

SMTPServer:<The SMTP server IP on domain1.com>

 

I'm sure the routing works and no traffic blocked.

 

 

Thanks.

 

Highlighted
Respected Contributor

Re: HP 360 G8 iLo 4and alertmail

The "sender domain" is required because ILO will use it's host name + that domain name as the "from" address.

For example, if you set that to "test.com" and your ILO has a hostname of "ILO-server", the email will be sent to the "email address" with a "from" of "ILO-server@test.com".

It actually uses the ILO's fqdn, so it may show the from address as "ILO-server.mylan.domain@test.com"... so if you have ILO using a FQDN, just be expecting that.
Highlighted
Occasional Contributor

Re: HP 360 G8 iLo 4and alertmail

Thanks.

We will take notice to that.

Actually we have few servers using iLo4

howeverall servers iLo didn't set fqdn (domain), meaning the field is blank.

But still cannot send email to email notification address.

 

By the way, any way to set a common from address for all servers?

do you know if 4 servers can set same iLo hostname ?

Assume no DNS Server on the same network segment

 

Thanks.

 

Highlighted
Respected Contributor

Re: HP 360 G8 iLo 4and alertmail

The from address comes from the ILO hostname and the "sender domain" you configure in the alertmail screen.

If it's okay for you to use the same hostname on multiple ILO servers, then that should be fine. Just to be safe, you should uncheck the option to register the hostname in DNS, just in case two machines ever did try to register on the same DNS server and overwrite each other's IP address.
Highlighted
New Member

Re: HP 360 G8 iLo 4and alertmail

Make sure you have entered an Domain Name under Network -> iLO Dedicated Network Port -> General

 

Otherwhise your <Mail From> - Adress for AlertMail will look like <Hostname>.@<SenderDomain>
Note the point between <Hostname> and @, this will cause Exchange Servers (Exchane 2013) to discard Alert Messages from this sender.

 

If you enter an Domain Name  it just works fine.
Your <Mail From> - Adress will look like <Hostname>.<DomainName>@<SenderDomain>...

 

Also make sure to use the IP-Adress instead of DNS-Name of the Mail-Server if you have not defined any internal DNS-Servers in Network -> iLO Dedicated Network Port - IPv4 Settings .