ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Who Me Too'd this topic

Advisor

iLO 4 firmware update failure, stuck on "Checking HP Secure Digital Signature" and 1% flash progress

Hello, I am trying to update the iLO 4 firmware on a ProLiant DL360p Gen8.   It's an ESXi host.  It's currently running iLO Firmware v1.5.1.  I am trying to update it to 2.61, same as our other servers.   I have done this update many times through the iLO Web Interface, by uploading the ilo4_261.bin file, etc.

A coworker of mine tried to update this particular server with this method, several weeks ago.  For some reason, this particular server has failed to update.  It is stuck on the screen of "Checking HP Secure Digital Signature" and at the bottom of the screen, indicates "Firmware Flash Progress: 1 %".  This never changes, it's been at this screen for weeks.  I see no option to cancel it, or try it again, etc. 

I have tried so many things to resolve this, here is a list:

  • Tried resetting/restarting the iLO itself from the Diagnostics page.  Though no errors are generated, it does not seem to actually restart looking at the iLO Event Log.  I believe this is because it thinks it's updating the firmware still.
  • This error / failure to update I'm seeing, is actually  mentioned in the HP iLO 4 user guide.  It says the resolution is to "hponcfg -r" from the command line.  I have done this from the /var/hp/tools/ install on ESXi on the server, and while it did succesfully reset settings to defaults, and wiped my user accounts out etc, the iLO still thinks that it's trying to update the firmware and the message is unchanged!
  • I also tried rebooting the iLO using a RIBCL script, that invokes the "<RESET_RIB/>" command.  This too runs as expected, no errors, but does not seem to actually reset at all.   The firmware still thinks it's updating, and remains unchanged.
  • I built a script to update the iLO firmware from the command line using hponcfg.  I verified the firmware location is valid (local, in the same folder) as are the user credentials.  This fails with the following error.  I can see this error in the RIBCL guide, and the error guide, but there is no explanation of what this error actually means or how to resolve it!  Very frustrating.  I am assuming that this error is just saying it's failing to flash, and perhaps that's for the same reason as why the WebUI didn't flash either? Here's the error in the full output:
/opt/hp/tools # ./hponcfg -f firmware.xml
HP Lights-Out Online Configuration utility


Version 4.4-0 (c) Hewlett-Packard Company, 2014
Firmware Revision = 1.51 Device type = iLO 4 Driver name = hpilo
iLO IP Address: 0.0.0.0
</-- ERROR :      STATUS= 0x005E
     MESSAGE= Open flash part failed. -->
Script failed
/opt/hp/tools #

I'm basically out of ideas.  The only thing left I can think to do, is to have the client go on site, and physically disconnect the server from power.  As this is a high availability host that is typically only remotely managed, I am trying to do whatever we can, to avoid that. 

Is there anything else that can be done to try and clear this error?  Thank you!

Who Me Too'd this topic