Server Management - Remote Server Management
cancel
Showing results for 
Search instead for 
Did you mean: 

Get-HPEiLOAccessSetting and iLO3 with 2.1.0.0/2.2.0.0

 
SOLVED
Go to solution
Highlighted
Trusted Contributor

Get-HPEiLOAccessSetting and iLO3 with 2.1.0.0/2.2.0.0

The cmdlet Get-HPEiLOAccessSetting fails when run against iLO3 systems. It is OK on version 2.0.0.1 and older, but not on anything newer.

When executed on 2.1.0.0 or 2.2.0.0:

PS C:\> $connection = Connect-HPEiLO 1.2.3.4 -Username administrator -Password admin123 -DisableCertificateAuthentication
PS C:\> Get-HPEiLOAccessSetting -connection $connection

IP            Hostname                        Status StatusInfo
--            --------                        ------ ----------
1.2.3.4       abc.123.com            ERROR HPE.Framework.Core.StatusInfo


PS S:\Scripts> (Get-HPEiLOAccessSetting -connection $connection).StatusInfo

Category Message                                                       AffectedAttribute
-------- -------                                                       -----------------
 General Error: Line #9: syntax error near "GET_FEDERATION_MULTICAST".

When executed on 2.0.0.1:

PS C:\> Get-HPEiLOAccessSetting -connection $connection

AuthenticationFailureLoggingThreshold : some value
EnforceAES3DESEncryption              : some value
HTTPSPort                             : some value
HTTPPort                              : some value
iLORBSUEnabled                        : some value
IPMIProtocolEnabled                   : some value
MinimumPasswordLength                 : some value
PropagateTimeToHost                   : some value
RBSUPostIP                            : some value
RemoteConsolePort                     : some value
RequiredLoginForiLORBSU               : some value
SerialCLISpeed                        : some value
SerialCLIStatus                       : some value
SessionTimeoutMinutes                 : some value
SSHProtocolEnabled                    : some value
SSHPort                               : some value
VirtualMediaPort                      : some value
ServerName                            : some value
ServerFQDN                            : some value
IP                                    : some value
Hostname                              : some value
Status                                : OK
StatusInfo                            :

There may be other cmdlets that break whilst interacting with an iLO3 interface. As far as this one is concerned, will this be addressed in a feature release?

Thanks.

3 REPLIES 3
Highlighted
HPE Pro
Solution

Re: Get-HPEiLOAccessSetting and iLO3 with 2.1.0.0/2.2.0.0

Hi,

HPEiLOCmdlets version 2.x ( 2.0.0.1, 2.1 and 2.2) all support only Gen8, 9 and 10 servers.

HPEiLOCmdlets version 1.x ( 1.5.x) supports only Gen7, Gen8 and Gen9 servers.

So accourding to the above supported matrix Gen7  i mean iLO3 is not supported by 2.x version.

We are not taking any new feature or bug fixes on 1.5.x version but you can raise a support issue to take it further.

Thanks,

Gokul

 


I am a HPE Employee

Accept or Kudo

Highlighted
Trusted Contributor

Re: Get-HPEiLOAccessSetting and iLO3 with 2.1.0.0/2.2.0.0

Certainly, G7 servers may not be supported on HPEiLOCmdlets 2.x.x.x, but many cmdlets do in fact work on G7 servers, the same way it works on Gen8/9/10. In this case, a 2.0.0.1 cmdlet that worked against a G7 system suddenly stopped working when using 2.1.0.0 and 2.2.0.0.

I suppose the underflying code in 2.1.0.0/2.2.0.0 broke the compatabiltry that worked when using 2.0.0.1. Unfortunately for me, as long as we have G7 servers to administer, I will have to stay on version 2.0.0.1.

Thanks

Highlighted
HPE Pro

Re: Get-HPEiLOAccessSetting and iLO3 with 2.1.0.0/2.2.0.0

Hi,

When we say Gen7 not supported that means the specified version of cmdlets is not tested against Gen7 server hardware.

But it might work as Gen8, Gen9 and Gen7 all uses RIBCL as interface for communication. May be something got changed recently in iLO3 (Gen7) which used to work for you in 2.0.0.1 but not in 2.1/2.2. The changes goes in 2.x release will be always tested against Gen8, 9 and 10 and make sure it works always.

I am afraid that i have to say Gen7 will not be supported in 2.x version but only in 1.x of iLO module.

Thanks,

Gokul


I am a HPE Employee

Accept or Kudo