Server Management - Remote Server Management
cancel
Showing results for 
Search instead for 
Did you mean: 

Redfish "@odata.type": "#AccountService.v1_3_0.AccountService"

 
Highlighted
Occasional Advisor

Redfish "@odata.type": "#AccountService.v1_3_0.AccountService"

When getting /redfish/v1/AccountService/ in https://ilorestfulapiexplorer.ext.hpe.com/ it shows:

{
  "@odata.context": "/redfish/v1/$metadata#AccountService.AccountService",
  "@odata.etag": "W/"DF31857A"",
  "@odata.id": "/redfish/v1/AccountService/",
  "@odata.type": "#AccountService.v1_3_0.AccountService",  "Accounts":   {
    "@odata.id": "/redfish/v1/AccountService/Accounts/"
  },  "ActiveDirectory":   {
    "AccountProviderType": "ActiveDirectoryService",
...

But when it in our Gen10 lab servers I get:

{
    "@odata.context":  "/redfish/v1/$metadata#AccountService.AccountService",
    "@odata.etag":  "W/\"8A194014\"",
    "@odata.id":  "/redfish/v1/AccountService/",
    "@odata.type":  "#AccountService.v1_0_2.AccountService",
    "Id":  "AccountService",
    "Accounts":  {
                     "@odata.id":  "/redfish/v1/AccountService/Accounts/"
                 },
    "Description":  "iLO User Accounts",
...

Notice that in our servers the AccountService version is 1.0.2 while in https://ilorestfulapiexplorer.ext.hpe.com/ it's 1.3.0. Also in our case all the active directory stuff is missing. I've tried this agains several of our Gen10 servers and I get the same result.

Do we need a firmware update or something to get a version with Active Directory support?

Thanks

 

1 REPLY 1
Highlighted
Occasional Advisor

Re: Redfish "@odata.type": "#AccountService.v1_3_0.AccountService"

Nevermind, I found out myself that with the iLO 1.40 update it works correctly.