Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

How to start upgrade from 6.3 to 7.3

 
Highlighted
Valued Contributor

How to start upgrade from 6.3 to 7.3

Dear all ,

 

I am very new to this tool, but worked with Many Hp testing tools.

Can anyone help me from sracth how to upgarde from 6.3 to 7.3 ?

 

Many thanks,

Avi.

13 REPLIES 13
Highlighted
Honored Contributor

Re: How to start upgrade from 6.3 to 7.3

You could read this PDF from page 50

 

http://h20564.www2.hp.com/portal/site/hpsc/public/kb/docDisplay/?docId=emr_na-c04030742

this is a upgrade from 6.x to 7.3 you could also consider installing a new server if your hardware/OS is not recent.

 

if you need hint for a fresh install next to the old as a replacement leg me know.

Kind regards,

Andrew
Highlighted
Valued Contributor

Re: How to start upgrade from 6.3 to 7.3

Hi Andrew ,

 

Thanks for the reply.

 

Its helps us how to start.. In the guide they mentioned that there is some tool for import and export database .. can you help me on this?

 

We have windows 2003 server for application with 6.3 version and SQL 2005 version for database and need to migrate these to windows 2008 for application-7.3 version and database is SQL 2008 R2 version.

 

Thanks,

Avi.

Highlighted
Valued Contributor

Re: How to start upgrade from 6.3 to 7.3

Or please help us in how to proceed with DB migration.

 

many thanks,

Avi.

Highlighted
Honored Contributor

Re: How to start upgrade from 6.3 to 7.3

I would recomend a new install on a new server so you can migrate and you still have a working SIM during migration.

first do an export on the old server, commandline mxnode -ln > c:\export.txt.

install your new server set the general credentials for login on the destination servers.

Now copy paste the list from the text file you created. If you can use the logon credentials you can set trusts, snmp and wbem settings with the repair option.

 

if you have a small enviroment you can consider a virtual server for SIM.

Kind regards,

Andrew
Highlighted
Valued Contributor

Re: How to start upgrade from 6.3 to 7.3

Hi Andrew,

 

Thanks for your reply.

 

We did fresh instalation without any issues. After we did data migration process by doing export and import .

 

Export was fine we are able to genarate products.zip then when we tried to import we are getting this attched error.

 

Please help us how to proceed further.

 

Thanks,

Avi

Highlighted
Honored Contributor

Re: How to start upgrade from 6.3 to 7.3

I always use the mxnode command, but did you run the import under a user that has rights in SIM ? Did you run it with an administrative commandline?
Kind regards,

Andrew
Highlighted
Frequent Visitor

Re: How to start upgrade from 6.3 to 7.3

Hi Andrew, thanks for the information. I am able to migrate the Insight manager from 6.3 to 7.3 version.

Could you please let us know what will be the steps after migrating to Insight manager 7.3 version. 

And should we perform any updates on clients?

 

Thank You

 Lohi


@Andrew_Haak wrote:
I always use the mxnode command, but did you run the import under a user that has rights in SIM ? Did you run it with an administrative commandline?

 

Highlighted
Honored Contributor

Re: How to start upgrade from 6.3 to 7.3

In the meanwhile there is a 7.4 version and hotfix november. If you have current hardware i would recommend updating your agents. One of the more recent updates were open SSL fixes. You can use SIM or SUM to update your servers drivers, agents and firmwares.

Kind regards,

Andrew
Highlighted
Frequent Visitor

Re: How to start upgrade from 6.3 to 7.3

Hi Andrew,

 

Thanks for the updates, but we don't want to upgrade the version. We just want to configure the clients to the current server(V 7.3). As we mentioned previously we are not aware of this tool, but with your help and going through other documents we are able to migrate the tool.  :-)

 

After migration we are getting the errors while running the  Discovery option, so we feel is any thing to update/configure from the client end. Below is the error we are getting from the client servers.

 

"Status: Completed with major errors

Exit code: N/A
Stdout:

********* Significant issues and overall target discovery/identification
status:
Minor: The name of the system could not be resolved to a fully qualified
domain name. For a Windows CMS, make sure that the domain name of
the managed system is included in the DNS suffixes in the Windows
Advanced TCP/IP Settings page.
Minor: The reverse DNS lookup using the IP address: 192.168.10.45 failed.
It might be that the nslookup timed out or DNS server cannot find
this address, or that the domain does not exist.
Minor: Verify that your name resolution service or the host file
configuration is configured properly so that your system's hostname
can be resolved to the fully qualified domain name.
Major: The system cannot be identified properly for HP SIM to manage;
unable to get one or more of the following: model, serial number or
unique identifier (UUID). For management processors, verify the
system is running the latest firmware. For Linux based operating
systems, you must have dmidecode installed, enable the
PermitRootLogin and PasswordAuthentication in sshd, and use root
sign-in credential. For HP-UX, verify the sign-in credential. For
Windows, check if WMIMapper is configured correctly on the CMS and
verify the sign-in credential.
Normal: Identification status is only available for servers, workstations,
or desktops, where monitoring is enabled.

********* Additional results (listed for information only):

* Starting identification process...
* Checking for known running web servers...
Minor: The system is unable to connect via HTTPS
* Checking for SNMP protocol support on system...
Normal: The system did not respond to SNMP. Verify security settings and
community strings in Options->Security->Credentials->System
Credentials
* Checking for SNMPv3 protocol support on system...
Normal: The system did not respond to SNMPv3. Verify security settings and
v3 credentials in Options->Security->Credentials->System
Credentials
* Running HP ProLiant management agent identification...
Normal: The system does not support SNMP.
* Running SNMP base cluster identification using common cluster
MIB...
Normal: SNMP is not supported or globally disabled, skipping SNMP cluster
identification.
* Checking for WBEM protocol support on system...
Major: WBEM is not enabled on the Central Management Server (CMS).
* Running WBEM rules based identification...
Major: WBEM is not enabled on the Central Management Server (CMS).
* Running Virtual Machine (VM) Host (non HP Integrity VM Host)
Identification...
Normal: The system is not a VM Host (non HP Integrity VM Host), or WBEM
credentials may not be specified so skipping VM Identification.
* Running Storage identification...
* Did not detect the WBEM protocol support on this system. SMI
storage identification will be skipped.
* Storage identification completed.
* Running HP NetServer identification...
Normal: The system does not support SNMP.
* Running HP-UX SNMP identification...
Normal: The system does not support SNMP.
* Running OA Identifier which will discover systems in an enclosure
if the automatic enclosure discovery option for OA is enabled...
Normal: The system is not an Onboard Administrator, skipping automatic
discovery of systems in the enclosure.
* Running XMLReply Identifier which will discover systems in a
rack/enclosure if the automatic discovery option for the container
node is enabled...
* Running iLO Identifier which will discover the server if the
automatic server discovery option for iLO is enabled...
Minor: The system responds to the HTTP request but cannot get the XML
output. It is normal for servers not to get the XML data.
Minor: If the http communication from CMS to target is working, but if it
is found to be slow then try increasing the Default connection
timeout parameter for http in global protocol settings.
* Running p-Class Identifier...
Normal: The system is not a p-Class so skipping p-Class identification.
* Running IPMI protocol identification...
Normal: IPMI protocol not detected so skipping IPMI Identification.
* Running SSH Protocol identification...
Major: Using SSH Protocol in discovery is disabled on the Central
Management Server (CMS).
* Running SSH Identification...
Major: Using SSH Protocol in discovery is disabled on the Central
Management Server (CMS).
* Running WS-Man identification...
Minor: The system did not respond to WS-Management (WS-Man) request.
* Running Monarch OA Identification...
Normal: The system is not a monarch OA so skipping monarch OA
identification.
* Checking for System Management Homepage and other HP web agents...
Normal: The system is not a server, storage or desktop. Skipping the check
for System Management Homepage.
* Running HP Serviceguard Identification...
* Running SNMP System Type manager ...
Normal: The system does not support SNMP.
* Running SNMP subtypes identification...
* Resolving DNS names...
* Checking if the Node is a Virtual Center...
Normal: Skipping MxVirtualCenter Identifier.
* Running Virtual Machine Management (VMM) Plug-in Identification...
* Building system relationships...
Minor: System Management Homepage (SMH) is not installed or is not
responding on the system(s).
* Running system Manage Communication diagnosis...
* System identification finished on system.

Stderr: None "

 

we have compare the old tool configuration to the migrated tool configuration, everything looks same in protocol and in Credential but when we discover servers we will get the above error. Could you please help us on this.

 

Thank You

Lohi