System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

B9007AAEVAL C.11.23.12.VAL HP C/aC++ Developer's Bundle

 
SOLVED
Go to solution
Highlighted
Frequent Advisor

B9007AAEVAL C.11.23.12.VAL HP C/aC++ Developer's Bundle

Hi Experts,

on my HPUX box running 11.23 v2 i would like to know if the ansi aCC+ evaluation copy is expired. How can i do this to know the status ?

10 REPLIES 10
Highlighted
Acclaimed Contributor

Re: B9007AAEVAL C.11.23.12.VAL HP C/aC++ Developer's Bundle

Well, if you run it and it has expired, it will tell you.
Highlighted
Honored Contributor

Re: B9007AAEVAL C.11.23.12.VAL HP C/aC++ Developer's Bundle

Check also codeword files - http://h20293.www2.hp.com/portal/swdepot/displayInstallInfo.do?productNumber=B9007AAEVAL

If they are missing it will show you an error.

regards,
ivan
Highlighted
Frequent Advisor

Re: B9007AAEVAL C.11.23.12.VAL HP C/aC++ Developer's Bundle

But IVAN It does not throw any error when i run the command aCC from my root login or user login.
Highlighted
Acclaimed Contributor

Re: B9007AAEVAL C.11.23.12.VAL HP C/aC++ Developer's Bundle

>It does not throw any error when i run the command aCC from my root login or user login.

Then it hasn't expired. Looking at the date of your codeword file would give you an idea when it expires.
Highlighted
Acclaimed Contributor

Re: B9007AAEVAL C.11.23.12.VAL HP C/aC++ Developer's Bundle

Of course you will have to compile something to get an error. A link or a -V won't give an error.
Highlighted
Frequent Advisor

Re: B9007AAEVAL C.11.23.12.VAL HP C/aC++ Developer's Bundle

Thanks Dennis,

here is the output from the command

root@agcdevdb / > aCC -V
aCC: HP ANSI C++ B3910B A.03.70

now does this mean its working ? or the below command am sure means that its looking for something

root@agcdevdb / > aCC -g prog.C
aCC: error 1913: `prog.C' does not exist or cannot be read


Finally Is the version above olsolete ? Whats the new Version ?
Highlighted
Exalted Contributor
Solution

Re: B9007AAEVAL C.11.23.12.VAL HP C/aC++ Developer's Bundle

Shalom,

These evaluation versions are very clear when they are expired. When you try and compile something, not a version statement they say:

They evaluation is expired.

Contact your HP representative for licensing.

The actual message varies slightly by product.

Current versions:
This bundle installs either of the following product versions:

* HP aC++/C version A.06.15 on HP Integrity servers.
* HP aC++ version A.03.80 and HP C version B.11.11.18 on the PA-RISC-based systems.


SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Highlighted
Frequent Advisor

Re: B9007AAEVAL C.11.23.12.VAL HP C/aC++ Developer's Bundle

Guys ! you guys have been of great and quick help as i wanted to reconfirm this if i was wrong. Everything looks good and fine on my setup now that we can focus on something else on an troubleshooting point.

Thanks again :)
Highlighted
Frequent Advisor

Re: B9007AAEVAL C.11.23.12.VAL HP C/aC++ Developer's Bundle

My Queries clarified