HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
BladeSystem - General
cancel
Showing results for 
Search instead for 
Did you mean: 

Impossible to add ssh key to OA.

 
Marc Campos
Occasional Visitor

Impossible to add ssh key to OA.


Hi,
I can't add a ssh key to a BladeSystem7000c chassis.

I known there are several posts about this problem but none solves my issue.

I try to:

# ssh Administrator@Blade7000cSystem
# set script mode on

[SCRIPT MODE]> add sshkey *MARK* ssh-dss AAA....... *MARK*

But the command never completes, it seems it's waiting for some input...
I supect it's a problem with the mark I use, if not, I can't understand...
I've tried thousands of combinations of marks with no success.

I also know that the key is valid because I have other chassis using this key (not configured by me).

Can anyone tell me a valid mark wich works??
Or any idea??

Thanks,

Regards,
Marc.

3 REPLIES
ojex
Occasional Visitor

Re: Impossible to add ssh key to OA.

Hi Marc,

from your example there i can see you are adding

*MARK* ssh-dss AAA....... *MARK*

are you forgetting the key size?

e.g: *MARK* ssh-dss 512 AAA....... *MARK*

My apologies if this is the first thing you checked, but I tried it on mine and without the keysize and it DID stall like it was waiting for the rest of the commend.

Cheers, gl, lemme know
Marc Campos
Occasional Visitor

Re: Impossible to add ssh key to OA.


Hi Ojex,

Finally I did it!

I tested adding the lenght of the key before it as you said, but didn't work...

I tested my command in another chassis (with no ssh key installed) and it worked, so I supossed it was a bug or something strange in that particular chassis.

So I restarted the OA and tryed again, and
it worked.

Next time, I'll restart the OA before anything...

Thanks for your help!


Cheers,
Marc.
Marc Campos
Occasional Visitor

Re: Impossible to add ssh key to OA.

As I said in the last post, I had to restart the OA to be able to set a new sshkey.

# ssh Administrator@OA
# restart OA