WAN Routing
cancel
Showing results for 
Search instead for 
Did you mean: 

MSR1000 Web Interface not working

 
Advisor

MSR1000 Web Interface not working

I have a new MSR1000 and I initially tried to set it up with CLI. Then I discovered that it has a web interface. So I restored to factory defaults (through the Ctrl B boot menu option 5), have a crossover cable connected and tried, per the instructions, to web access http://192.168.1.1 

 

No joy.

 

Can't ping that address either, so CLI'd the interface address to 192.168.1.1 and then I could ping it but could not access the web console.

 

What am I missing? I do not see where there is an httpd I can start or stop.

 

Sorry to be obtuse - but wow that CLI is complex and confusing! And all I want to do is connect the metro ethernet WAN on one port to my firewall on the other.

4 REPLIES 4
Advisor

Re: MSR1000 Web Interface not working

Found it.

 

I did have to set the interface to 192.168,1,1 in the cli:

 

system-view

interface gigbitethernet 0/0

ip address 192.168.1.1 255.255.255.0

 

then,

system-view

ip http enable

 

and now it's accessible (from a laptop connected to the WAN port 0/0 with a crossover cable, the laptop hardcoded to 192.168.1.2

Advisor

Re: MSR1000 Web Interface not working

OK. well I'm closer.

 

But trying to login with admin/admin and the verify code shows, on a console connection:

 

admin failed to login from web, reason is 3

 

 

Advisor

Re: MSR1000 Web Interface not working

Holy moly, they don't make it easy.

 

from page 70 of the 169 page fundamentals guide:

 

# Assign the IP address 192.168.0.58/24 to interface Ethernet 1/1 (the interface connected to the PC). system-view [Sysname] interface ethernet1/1 [Sysname-Ethernet1/1] ip address 192.168.0.58 255.255.255.0 [Sysname-Ethernet1/1] quit # Create a local user named admin, and set the password to admin for the user. Specify the Web service type for the local user, and set the command level to 3 for this user. [Sysname] local-user admin [Sysname-luser-admin] service-type web [Sysname-luser-admin] authorization-attribute level 3 [Sysname-luser-admin] password simple admin

 

so now at last I can run the basic configuration wizard

Valued Contributor

Re: MSR1000 Web Interface not working

I know this thread is old; however I had a very similar problem at a HP MSR1002 4 AC Router (JG875A) router with firmware version R0306P30. (The router was new and original sealed; - I get it at eBay for an awesome good price.)

However, in my case the original installed firmware had simply no support for a web interface. The ip http enable command was not accepted and did nothing.

So, holy moly, HP really doesn’t make it easy, they made it in my case even more complex!

I had to go the harder way and update the firmware over a TFTP server client (Tftpd64 by Ph. Jounin). A long time ago I did this already at a 3Com 4200G Gigabit Switch. So after some testing I figured it out and it worked.

After the upgrade to firmware R0707P24 I was finally able to apply the ip http enable command and activate the web UI.

So my steps were:

A console connection to the MSR router was established and an IP address was defined. I decided me for the ip address 192.168.0.1 255.255.255.0 (at the Gigabit interface connected to the computer). Note, the port must be configured as port link-mode route and not as port link-mode bridge, otherwise no IP address can be applied.

As already described in the previous post, also a local-user admin with web and SSH permissions must be set. It is recommended to configure also the date & time manually.

The LAN port at the computer was manually set to 192.168.0.2 255.255.255.0 and the TFTP server client was installed and correctly configured (the firmware directory was selected).

Then I load the new firmware at the router CLI with:

tftp 192.168.0.2 get MSR100X-CMW710-R0707P24.ipe

The next step will extract several files to the internal flash and set the new firmware as default:

boot-loader file flash:/MSR100X-CMW710-R0707P24.ipe main

Both bootware, main and backup, were updated after the reboot.

Now I was able to activate the web UI with ip http enable and login. Because the internal flash was quite full, I downloaded the older firmware files to the computer and delete them in the flash. Also the *.ipe firmware file which is effectively a type of an archive can be deleted after the fw upgrade is processed. This will give additionaly some more free space.

That’s it, I hope this will help also other MSR users.