ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Can't configure RAID on ML10 v2 (B120i controller)

 
SOLVED
Go to solution
Highlighted
New Member

Re: Can't configure RAID on ML10 v2 (B120i controller)

Hi,

I confirm...

 

1. download the HP SSA from link above

2. burn the ISO on a DVD or make a USB PEN (with HP USB Key Creator Utility Version 2.0.0.0)

3. start the server with DVD or PEN

4. SSA starts and you can configure the ARRAYS and DISKS

5. start OS installation and use the controller drivers in SPP (cp025591.exe for SRV2012 - read content.html)

 

.... very hard work ...

 

Highlighted
New Member

Re: Can't configure RAID on ML10 v2 (B120i controller)

I finally got my install going by using the driver from the SPP for the 120i controller. I was looking right at 120 on the screen instead of the 140. Soon as i copied the right one to the usb I was off and running. Aaron

Highlighted
New Member

Re: Can't configure RAID on ML10 v2 (B120i controller)

I need help - I suspect I'm misunderstanding something, but it's possible I've bought the wrong bit of kit! Apologies in advance for wall of text, I'd really appreciate some help.

 

My aim is to have a server runing Windows 7 from an SSD, with 2x 3TB HDD acting as one (RAID 0) 6TB drive for data storage. I'm then going to install plex server on it. I thought the HP Proliant ML10 v2 would be able to do this. To be fair, Windows 7 isn't a necessity, I just need an OS that will run Plex Server.

 

So, I've connected the 2 x 3TB HDDs to - what I'm assuming is - the RAID SATA cabling inside the unit, using cables labelled with stickers 1+2. I'd like to set these up in a RAID 0 configuration so they are idenified by the OS as one single 6TB drive.

 

And on to the first problem - after enabling B120i RAID Controller, pressing F5 to get to the RAID config menu doesn't work, I get a 'boot disk missing' (or something similar) error...

 

As per the instructions on this thread, I've downloaded SSA and - after MUCH searching - I found a working download link to version 1.7 of HP USB Utility tool. As my main PC is running Windows 8.1 I had to install/run the software in compatibility mode, but eventually it seemed to work and I'd made a bootable USB. Or so I thought.

 

 

The bootable USB I've made has kind of worked, but it seems the GUI doesn't launch properly as the machine attempted to boot from the USB (I get a 'X Server not found' error). So instead, it stays in a command line style view, and I have absolutely no idea how to get the desired result, evena after reviewing the 'help' command/list.

 

Can anyone provide me with instructions or a link to some resources that might help? I've heard there is a version 2.0.0.0 of the USB utility that works with Windows 8.1 natively, if someone could provide a working download link I'd be happy to try it, (alas my own google/HP searches have proved fruitless).

 

Secondly, regarding the 120GB SSD which I'd like to install the OS on (Windows 7 Ultimate - I'm aware this isn't a server specific OS but it should work for my needs and I have a spare license) - which cabling should I attach this to? It's own SATA cable or attach it to the chain of RAID cabling with the other HDDs I've got?

 

Lastly - at one point I actually tried to skip all of this RAID creation malarky and just install Windows, but to do so I had to switch the BIOS to AHCI mode, otherwise the Windows installer wouldn't see the disks. Assuming I get the B120i RAID controller to work, will I have this problem again?

 

Any help or advice would be really appreciated

Highlighted
Honored Contributor

Re: Can't configure RAID on ML10 v2 (B120i controller)

With the support site splitting between HP Inc and Hewlett Packard Enterprise the link to HP SSA has changed

 

New link

http://h20564.www2.hpe.com/hpsc/swd/public/detail?swItemId=MTX_61a46dea0eb1438ba0cf6deaba&lang=en-us&cc=us

 

v1.7 of HP USB key utiltiy is what is embedded in the ISO image. I haven't tried creating a USB key under Windows 8.x so I can't say if it will or will not create the USB key properly.

 

This is the link for v2.0 of the USB key utility

http://h20566.www2.hpe.com/hpsc/swd/public/detail?sp4ts.oid=7271242&swItemId=MTX_948972949139480992fcb5b558&swEnvOid=4168#tab-history

 

 

When the controller is in B120i Dynamic RAID mode you will need a special driver as the RAID functionality is actually contained in the driver. There is not a driver for WIndows 7, the Windows 2008 driver might work, but regardless Windows 7 is not a support OS on this server.

No support by private messages. Please ask the forum! 
Highlighted
Occasional Visitor

Re: Can't configure RAID on ML10 v2 (B120i controller)

Thank you Jimmy for this post! Ive spent all night trying to install Server OS on a ML10v2. Finally at 7 in the morning I'm on my way thanks to the solutions in your post.

Nothing worked as described in the documentation by HP for this server. The SPP downloaded from HP could not boot no matter what media I used or how I created create the USB key.  The disks were not recognized by the B120i controller.... Not what you expect from HP....

Highlighted
Honored Contributor

Re: Can't configure RAID on ML10 v2 (B120i controller)


uteghp wrote:

Thank you Jimmy for this post! Ive spent all night trying to install Server OS on a ML10v2. Finally at 7 in the morning I'm on my way thanks to the solutions in your post.

Nothing worked as described in the documentation by HP for this server. The SPP downloaded from HP could not boot no matter what media I used or how I created create the USB key.  The disks were not recognized by the B120i controller.... Not what you expect from HP....


Glad you got things goind and sorry you had issues with the SPP. The SPP is bootable and does include HP SSA. I think the latest version requires HP USB key utility v2.0 to create a bootable key

No support by private messages. Please ask the forum! 
Highlighted
Occasional Visitor

Re: Can't configure RAID on ML10 v2 (B120i controller)

Hi

 

Followed everything on jimmy's Guide. But when i try to install the raid driver using CP025591 its says its a driver for B140i. 

Highlighted
Honored Contributor

Re: Can't configure RAID on ML10 v2 (B120i controller)


@AYSMAN wrote:

Hi

 

Followed everything on jimmy's Guide. But when i try to install the raid driver using CP025591 its says its a driver for B140i. 


Not sure where you got that file, but it is indeed for the B140i and not the 120i. You want cp024079

 

SPP contents listing

http://h50146.www5.hp.com/products/software/oe/linux/mainstream/contents_spp2015060.html

 

HP Dynamic Smart Array B120i/B320i SATA RAID Controller Driver for Windows Server 2012 and Microsoft Windows Server 2012 R2 x64 Editions 62.12.0.64 Recommended cp024079.exe

     

 

Dynamic Smart Array B140i Controller Driver for Windows 2012/2012 R2 x64 62.4.0.64 Recommended cp025591.exe

 

 

No support by private messages. Please ask the forum! 
Highlighted
Occasional Advisor

Re: Can't configure RAID on ML10 v2 (B120i controller)

Hi to all,

 

    I have same problem in HP Proliant ML10 V2 i cannot configure sa HP Smart Array and the screen upon power up stated Array no Configure. Wha procedure do i need to do so that i can start the installation in our New Proliant ML10 V2. Take note this is fres from the box.

 

   Also the Hp Proliant ML10 V2 support windows 2003 server r2?

 

Thank You

Highlighted
Honored Contributor

Re: Can't configure RAID on ML10 v2 (B120i controller)

You need to download either the HP SPP or the offline version of HP SSA.  links are provided in this thread

No support by private messages. Please ask the forum!